Can't power off raspberry pi 400

I'm using Mate 20.10 on a Raspberry pi 400 everything works fine except when I log out and power off,the Pi power light goes off but the log out script stays on the monitor. (if this makes sense) When I go to restart the pi, It wont power on unless I unplug it and then plug it back in. Then it powers on and works as normal. I first noticed this problem when I connected a powered usb hub. I could keep plugging and unplugging the Pi but I would rather having it work right. Any advice? thanks

I don't know how the dsplay on the monitor is maintained, but the power behaviour is otherwise like one of the main-sequence Pi's, where after a power-down sequence you need to switch off power and switch it on again to get boot-up.

I also have regular ubuntu and raspberry pi os on other sd cards and they work normally. I also tried to power off after booting up and powering off at the login screen. The same thing happens.

Maybe this will help.image1


same Problem with the Raspi400 and Ubuntu Mate.
I think its a problem with the lat update "linux-headers-5.8.0-1010".

is there a solution for this problem?


The bug is fixed in firmware version 5.8.0-1010

It's not fixed. Upgraded the firmware and still not able to power down.

I have the exact same issue same simptoms. Reboot: Power Down. Screen does not turn off except maybe once in 10 times it shuts down normlly. Hve to unplug power and power back on to boot.

I was about to say that the problem was fixed,but like tas100x said,it only shuts down normally a few times. Very Frustrating.

I have this exact same problem. About once every few times, the display script goes away and it does shut down.

I assume this is specific to the Pi 400.

I also am not holding my breath to see if this ever gets fixed, so I just unplug (old school!) after it reaches the end of that screen.

Okay okay, I think the developers are screwing with me. I ran an update, the Pi powers off just fine. But now it won't power on unless I unplug it and plug it back in. I think I'm starting to have fun with the quarks on the Pi400 using Mate.

This is an update on the pi400 with an SSD from my previous post. 2 weeks ago the issue was suddenly resolved after an update. powers down just fine and turns on from keybd just fine. now suddenly after another update still powers down ok but now have to disconnect power and reconnect to come back on. NOTE I also have a PI 4b using an argone One M.2 case and drive and do not have this problem.