Can't remove Chromium entry from Preferred Applications>Web Browser in Control Center

I'm using the Mozilla-provided install of Firefox instead of Ubuntu's, because of an issue with KeepassXC and snap.

When I went into the Web Browser setting, I somehow clicked on Chromium, which is the only entry in the drop down. Now I can't get rid of it, so web links now bring up Chromium, which isn't what I want.

I would be happy just to get it cleared out, but even happier if I could replace it with my custom Firefox.

If I need to go to a config file to fix manually, that would be fine too.


Try deleting Chromium. Then try to change the default app or just click on a link and see what happens. Afterwards, reinstall Chromium if you still want it on your system.

Another possibility is to open Firefox and look for the setting that makes it the default browser.


Along with @mdd12 's option maybe check if Firefox is set as default and if for some reason Chromium is too. Also open Firefox and then while it is open check preferred applications and see if Firefox is now there. Have had issue with T-bird on my system where it didn't see it unless it was open. Just more things to try. Can't speak for Chromium as it was first gone when I installed MATE.


Thanks to both of you. When I installed Firefox I made it the default browser when it asked me. And when I have gone into FF settings I have noticed that it was set as the default browser.

When I recently clicked Web Browser in Preferred Apps, Firefox was not listed and Preferred Apps defaulted the web browser to Chromium, which was listed.

Just now, I simply went back into Firefox settings, and saw that FF was no longer the default browser so I checked the box to make it the default. I then went back to Pref Apps and saw Web Browser set to FF. I also saw that Chromium was still a choice on the list.

So I'm where I should be now - FF is now an option in Pref Apps and it is the selected option, while Chromium is a non-selected option.

Thanks a lot for you suggestions. :slight_smile: