Can't run QuickTime .mov videos from iPhone on Ubuntu Mate 16.04

I am considering installing Ubuntu Mate 16.04 on a variety of machines, so I am trying it out on an old laptop first.

This is a Gateway ML6226b with 1 MB of RAM and
Intel® Graphics Media Accelerator 950
The processor is a Celeron 520 running at 1.60 GHz.

In 32 bit mode, on startup, after start System Monitor, about 405MiB gets used.
(In 64 bit mode (using the Live DVD), on startup, after start System Monitor, about 525MiB gets used.)

The 32 bit install went fine and I have brought it up to date with Software Updater.
I chose options for 3rd party software (Flash and other media etc.) at install time, and did these installs:

sudo apt-get install ubuntu-restricted-extras
sudo apt-get install totem

Apparently totem (Media Player) was not installed automatically?
Oh, and I also installed VLC from the Boutique, I think.

Both Media Player and VLC work fine on .avi and .wmv files
They work fine on an early QuickTime file (352x288 pixels) created about 12 years ago and probably without soundtrack.

However they don’t work on QuickTime files from an Apple iPhone 4s.
On VLC the sound is OK but the video is just one static frame.
On Media Player (totem) there is sound just at the begining; video is about 1 frame every 5 seconds.

Are there any solutions or work-arounds for this?

Can you share such a problematic video file here for others to test?

I have put a file in Dropbox


I just played your video using SMPlayer and I didn’t encounter any issues.

Could you please try SMPlayer?

VLC is installed by default.
Totem is not the standard player for Ubuntu MATE.
As @orschiro recommended, you can also give SMPlayer a try:

sudo apt install smplayer

It’s possible the files you’re attempting to read were corrupted during the copy to your computer.

The file I put onto dropbox was one of the ones that were giving me problems.

That works a lot better. I see the video and hear the sound (but they are out of sync - the sound finishes long before the video).

I also get this error:

By the way, can you all tell me what hardware you are using? Do you have dedicated graphics cards?

Mine is a ten year old laptop as described above.

I don’t really have any advice, but I can help you test.
I play .mov files from my IPhone 6s just fine with VLC.
I can play your video in VLC and the audio is synced.
I haven’t tried SMPlayer.

HP Folio 13
description: System memory
physical id: 0
size: 3897MiB
product: Intel® Core™ i3-2367M CPU @ 1.40GHz
vendor: Intel Corp.
physical id: 1
bus info: cpu@0
size: 1398MHz
capacity: 1400MHz
width: 64 bits
description: VGA compatible controller
product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0

Please make sure mpv is installed and SMPlayer uses it:

It wasn't, so I did

$ sudo apt install mpv
    Suggested packages:
      ffmpeg-doc sndiod
    Recommended packages:
      va-driver-all | va-driver
    The following NEW packages will be installed
      ffmpeg libavdevice-ffmpeg56 libguess1 librubberband2v5 libsdl2-2.0-0 libsndio6.1 libva-wayland1 mpv rtmpdump youtube-dl
    The following packages will be upgraded:

Then in SMPlayer's preferences, I changed


Now it runs without an error message, but the video and audio are still out of sync.

In SMPlayer's preferences, I set synchronisation on thus:

That had no effect.

The mpv log includes:

Audio/Video desynchronisation detected! Possible reasons include too slow
hardware, temporary CPU spikes, broken drivers, and broken files. Audio
position will not match to the video (see A-V status field).

Well, so maybe your hardware is indeed too old to play a simple video…I am sorry, but I have no further ideas.

Yes, I think that may be the case. There are a lot more pixels in these iPhone videos than in my other files. At least now I have found SMPlayer which works better than the other software I tried.

I’m just testing out 16.04 on this old computer. If I find there are no deal breakers, I will install it on my current laptop (a Toshiba with Intel graphics and dual core processors) which might work better.

1 Like