Can't update system or install box64

it started with updating pi apps, it had to uninstall box64 and reinstall it to update, but it failed to install, i tried reinstalling it afterwards, and it still wouldnt work. after looking into the files to see what was happening, i found logs about the install fail, i went to the discord link it had and then they said some apt files were broken. i tried updating, and it failed and said this: E: The repository ' impish Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

The PPA that you have added there does not publish any packages for 21.10 Impish release. The error message you are receiving is because apt doesn't know how to proceed because there is nothing it can use in that repository. If you remove that PPA you should be able to do normal updates again but that doesn't exactly help with the software you are trying to install. Can you post a link to the article you followed to install box64?

what do i do from here?

I suggest unchecking the one directly above the line you have highlighted. It will allow you to do normal updates again.

The PPA you have here is for Gwibber. This is what shows for the description:

Description: Open source social networking client for GNOME
 Gwibber is a social networking client for GNOME. It supports Facebook,
 Twitter,, StatusNet, FriendFeed, Qaiku, Flickr, and Digg.
 This package includes the Gwibber desktop service
Python-Version: 2.7

I don't think that got added (from my brief look at the install scripts) during the pi-apps and box64 install.

i was able to finish the update, but it still wont let me install box64. I do see something that doesnt seem right though.

Before trying to install box64, what was the result of sudo apt update && sudo apt upgrade in the terminal?

the update details can be seen above and the exact same as the first attempt after following your directions, after running the upgrade command, it said there was nothing changed

and now i cant upgrade to 22.04

also idk if this helps, but i also switched to a different raspberry pi 400 and i think thats when it started happening.