Change time interval notification shows


#1

When I boot up, I get a message saying that I am connected to the internet.

Is there a way to change the time interval for that message and the one that shows when I am offline?


#2

Can you clarify what you are trying to accomplish? Do you want to change the time before connection is made, or lengthen the time the message displays, or something else?

It will also matter to know what your system is and how you are connecting to the internet.


#3

I want to shorten the time that the message is shown.

I connect to the internet via an ethernet connection.

What do you mean by what my system is?
Ubuntu Mate 18.04?


#4

I can't find a way to adjust that. And, if I understand correctly this wiki entry (under "bubble behavior"):

https://wiki.ubuntu.com/NotifyOSD#Animations%20and%20durations

It is hard coded according to the importance of the notification and can't be changed.


#5

You are talking about notifications, correct? Searching on "ubuntu: notifications" brings up some interesting items.

http://ubuntuhandbook.org/index.php/2016/05/customizing-notification-bubbles-ubuntu-16-04/

See - https://www.fossmint.com/notifyosd-desktop-notification-bubbles-in-ubuntu/ for more of the same.

Installing both the patched version of notify OSD and the configuration tool for notify OSD enabled some control over notifications.

Use grep -r org.freedesktop.Notifications /usr/share/dbus-1/services/ to see what might control your notifications. Disabling one or two of these may help your system. Your mileage may vary.

I also found a way to suppress the wireless/network notifications using dconf entirely.

org, gnome, nm-applet, check disable-connected-notifications and also disable-disconnected-notifications.

Good luck Andy.


#6

I installed it. However, it does not work correctly.

I had it set to 2 seconds and to show in upper right corner.

The message(no bubble) showed up in the middle of the screen and it never went away without me having to click on it.


#7

Have you used Applications-> Accessories-> Notify OSD ? A dialog box should appear. Change an item in Behavior and click on Apply.


#8

After a reboot, it did work.

Thanks so much.