Cheese can't find camera

I use Zoom once a month for a meeting. It worked last month, but could not find my camera this month on my System 76 Darter Pro computer. I quickly got out my old HP ProBook 6565B. Exact same issue, camera not found. I looked in the forum and found the command "lsusb" and it found the camera. I then found the alternative "guvcview" by using this forum, and installed it and my laptop's camera worked again.
Has anyone else been having this trouble with Cheese? It seems to have happened after the last software update. Could it be a software bug? It happened on two very different laptops.

Out of curiosity, have you tried Webcamoid, the new default «webcam» app for Ubuntu MATE since 20.10 ?


  • Take pictures and record videos with the webcam.
  • Manages multiple webcams.
  • GUI interface.
  • Custom controls for each webcam.
  • Add funny effects to the webcam.
  • +60 effects available.
  • Effects with live previews.
  • Translated to many languages.
  • Use custom network and local files as capture devices.
  • Capture from desktop.
  • Many recording formats.
  • Virtual webcam support for feeding other programs.

Hi :slight_smile:
Can you try running those commands in terminal ?

export LD_PRELOAD=/usr/'$LIB'/libv4l/

and see if it works :slight_smile:

No I have not. I will look into it thanks.

1 Like

I have Cheese removed at this time, but I can re-install and give it a try. It still seems odd that it happened on two very different laptops with two different cameras. I will get back to you.

1 Like

Thanks for the responses. I decided just to go with Webcamoid. I have had to many problems with Cheese over a very short amount of time. I now have two alternatives with webcamoid and guvcview. I think that I should be able to keep my camera working. On my main computer it is a "chicony usb 2.0 camera". I have not checked yet what it is on my old backup laptop.

1 Like

Worked for me!!! Cheese finds my webcam. But I have to run commands every time when open cheese.