Chrome Remote Desktop use

Has anyone tried using Chrome Remote Desktop? If so, have you been able to get it to use your local default session?
I have it working and am connecting in 15.04 but when I connect it looks as if I am getting a different session and not the same session I have running locally. Also, I use dual monitors on my machine and if I connect remotely, I do not have the option of dual screens.
I’ve tried following Google’s recommendation for creating the .chrome-remote-desktop-session in my home directory with the following entry:

exe /usr/sbin/mate-session

But it doesn’t seem to do anything, Chrome Remote Desktop runs the same with or without that file.

I don’t have a solution but I thought I’d share my experience with using Chrome Remote Desktop on ubuntu mate 18.04

My desktop totally crashed. It screen went all black, with an error popup saying something like “username is not detected in this session bus” something or another.

I had to disable the remote connection from my laptop and I think everything’s back to normal but I have yet to check my desktop for any errors.

Of course, needless to say, I didn’t know what I was doing it, but man, it shouldn’t have blacked out my screen like it did.