Chrome users | Update broken | Solution here

Hi, if like me you use Google Chrome browser the latest 18.04 UM update does not run after updating due to Google changing part of the repository information, in fact both command line and graphical update methods fail after the change. Here is the solution in case you are stuck.

From the "software and updates" application (System/Administration if like me using the Traditional theme) select the "Other Software" tab and UNTICK the entry for Google Chrome as seen below (not the highlighted one, that's mega)

After that, exit and update as prompted. Either then through the command line or graphically from the software updater, update. Then go to the software boutique and find Google Chrome. There should be a "reinstall" option (yellow box) - do this (or through the cmd line) and once reinstalled, the problem should be fixed as the reinstall will fix the repository change and re-tick the option in the Software and Updates application. (I know it is apt-get/ppa etc underneath but users like me still sometimes like the GUI).

Not a complex fix to this, but unless someone shows you, you may scratch your head and think Linux is bad, when it is not.

Hope this helps someone


1 Like


It sure does help me and thank you!

I could not figure out why when updating I was getting the failure message and never even thought about it being Chrome.

Much appreciated.

This is from [Andrea Olivato]'s post.

Well, backstory apart, there’s an easy fix. Just run
sudo apt update
And you will be prompted to accept the new Origin of the repository
Do you want to accept these changes and continue updating from this repository? [y/N]
And that’s it.

1 Like

Thanks for that as well.

Great tip for me as a newbie!

I tried the “sudo apt update” in place of “sudo apt-get” as noted here, stackoverflow and ubuntu forums. Not sure why it did not work, but it did not bypass the situation.
andyp6’s method allowed chrome to update, thus worked around the broken PPA.

Thnx everyone,

Thanks all, its precisely because a sudo apt-get update didnt work that I posted my solution.

Right on.

I am still having issue’s after all. I retried all steps listed above to no avail.

Here’s what I get:

N: Skipping acquire of configured file 'contrib/binary-i386/Packages' as repository ' bionic InRelease' doesn't support architecture 'i386'
W: GPG error: trusty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 379CE192D401AB61
E: The repository ' trusty Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Worked like a charm. Thanks for the tip.

Hi if you still have the issue try unticking anything relevant to marshallofsound, updating list and installing updates, then you perhaps should reinstall the application.
Its not an application im familiar with.