Chromium won't load any page (http or internal)

Hi all
First time posting. I use various flavours of Ubuntu on many devices and PCs. New to Mate though.

I have a Raspberry Pi 3. Changed from Raspbian to Mate about a month ago. I’m running it with all updates and firmware updated. But Chromium is not working. It will load, and then show the “oh, snap” page. I can’t load settings, or any internal page or webpage. It just sits there with “oh, snap”. It does show that my profile is logged in though.

I’ve tried removing and reinstalling (clearing apt cache in-between). I’ve found a few posts on this forum from a year ago where Chromium was crashing and not loading, and tried those command line switches, but those never worked.

My Chromium is loading, unlike those. It just goes no further.

Any help or input would be welcomed, fixing this or pointing me in a direction to troubleshoot.

Thanks in advance :slight_smile:

Hi and welcome
What error message, if any, do you get when starting the browser from the command line?


Thank you for the reply.
I’ve just checked for any updates for Mate again.

When I run that command from a terminal, Chromium does open. It also puts a load on RAM, but not CPU.

The output is as follows:

chromium-browser --type=renderer --enable-pinch --primordial-pipe-token=5329A642E3670026EFB6CE08CC344402 --lang=en-US --instant-process --enable-offline-auto-reload --enable-offline-auto-reload-visible-only --enable-pinch --num-raster-threads=2 --enable-main-frame-before-activation --content-image-texture-target=0,0,3553;0,1,3553;0,2,3553;0,3,3553;0,4,3553;0,5,3553;0,6,3553;0,7,3553;0,8,3553;0,9,3553;0,10,3553;0,11,3553;0,12,3553;0,13,3553;0,14,3553;0,15,3553;1,0,3553;1,1,3553;1,2,3553;1,3,3553;1,4,3553;1,5,3553;1,6,3553;1,7,3553;1,8,3553;1,9,3553;1,10,3553;1,11,3553;1,12,3553;1,13,3553;1,14,3553;1,15,3553;2,0,3553;2,1,3553;2,2,3553;2,3,3553;2,4,3553;2,5,3553;2,6,3553;2,7,3553;2,8,3553;2,9,3553;2,10,3553;2,11,3553;2,12,3553;2,13,3553;2,14,3553;2,15,3553;3,0,3553;3,1,3553;3,2,3553;3,3,3553;3,4,3553;3,5,3553;3,6,3553;3,7,3553;3,8,3553;3,9,3553;3,10,3553;3,11,3553;3,12,3553;3,13,3553;3,14,3553;3,15,3553 --disable-accelerated-video-decode --disable-webrtc-hw-encoding --disable-gpu-compositing --service-request-channel-token=5329A642E3670026EFB6CE08CC344402 --renderer-client-id=3 --v8-natives-passed-by-fd --v8-snapshot-passed-by-fd: pthread_getattr_np.c:71: pthread_getattr_np: Assertion `abs (thread->pid) == thread->tid' failed.
Received signal 4 <unknown> 0000723833f6
#0 0x000076e6ddd2 base::debug::StackTrace::StackTrace()
#1 0x000076e6e10c <unknown>
#2 0x000072383270 <unknown>
#3 0x0000723833f6 abort
[end of stack trace]

This looks like a bug in chromium.
May I ask how you installed it? (Was it from the Software Boutique?)

Thanks for the feedback!

I don’t think it was from Software Boutique. I found that very slow, and cumbersome.
If I’m remembering correctly, I used Apt from the command line.

Again, I’ve checked for updates with both Apt and for Pi firmware. All up to date.

If it is a bug, hopefully there will be a fix / solution soon.
I found something from early 2016 with similar issues, but that was seemingly fixed on subsequent updates.

Is firefox working? If it doesn’t, then the problem could be the OS…:sunglasses: