Clipit won't launch in Mate

Upgraded this computer from 18.04 to 20.04.2 just a few days ago.

After getting up and running, installed Clipit using Synaptic Package manager in Mate 1.24.0. Rebooted. Clipit will not launch from the task bar, or from 'Applications'. Rebooted and brought up the different desktops I have and tested Clipit on each desktop.

Clipit works fine in Unity, Ubuntu, and Cinnamon. But fails to launch in Mate & Gnome.

Back in Mate, I again used Synaptic to download and install CopyQ. It also doesn't launch. Many of the other apps launch fine (haven't tried every app though).

I use ClipIt all the time and would like to have it working in Mate as I like Mate the best out of the various desktops I have. But I MUST have a working Clipit OR CopyQ for projects.

Anyone have a cure for Clipit not launching in Mate?


Hi, I just tried installing clipit from the terminal as I wanted to see what happened when launching it from the terminal and got welcomed with this:
Capture du 2021-03-04 19-06-48
You might want to try diodon instead.
sudo apt install -y diodon if you want to install it.

I have been using CopyQ for over a year and when I first installed it, on first launch, an icon appeared in the notification area of the panel but there was no full screen app. You can open the user interface by right-clicking the icon and choosing from the menu.

I run CopyQ on macOS, Windows, and Ubuntu MATE and use Barrier to sync the clipboard between all 3 machines. I don't remember which OS required a change to the keyboard shortcuts, but I have ensured that all 3 use < Ctrl > + < Meta > + V (where "Meta" is the Windows/Command key on the other OSs) to display the main window. As a result, I now have CopyQ in my startup apps and hide the panel icon altogether.

Hope that helps some.

I was able to install Diodon from Synaptic and rebooted. It shows up in Apps but it doesn't do anything. Doesn't show any Ctrl C or right click Copy items I've tried.

Is there some secret way to get it to open? I can set properties, but it doesn't collect Copies I've tried so far.

Just copied a block of stuff from a Spreadsheet and the Diodon shows it's Empty.

Ctrl+WindowKey+V does not bring up CopyQ interface.

diodon works for me.
Had to log out/log back in after installing it though.

I'm on 20.10, clean install though.

I rebooted after install of Diodon and that didn't fix it, still didn't work. I'm on a fresh (recently installed) version 20.04.2 upgrade to an 18.04 working setup. 'Mate' desktop is the latest version. Clipit didn't work in Mate in 18.04 either for a couple years. So I tended to use Cinnamon instead, where it worked fine.

This really looks like 'something' in Mate is blocking these programs in my setup.


I completely uninstalled Clipit from Synatic, then check it was gone in Term. Rebooted into Cinnamon. In Cinnamon both Diodon and CopyQ work fine.

Rebooted into Mate and Diodon works! but CopyQ doesn't work so I'm going to delete that one. As long as Diodon is working, don't need it.

Thanks everyone, for the info. I never got that 'Diodon instead of Clipit' message.

1 Like