Clock applet has stopped showing weather information

You're right.
Luckily there is a patch for it. We're discussing that at the moment in this thread

You still have to apply the patch manually but I think that a fix will be in the updates within reasonable time because all ubuntu-MATE versions from 22.04 to 23.10 are affected.

2 Likes

The 20.04 here at home, and the 18.04 I have at work are also effected, and this is not recent for me, it's been going on for over a month. I just didn't feel like being the squeaky wheel that revived the topic.

I understand.

The problem is that the URL of the weatherstation (where the weather-app gets its info from) has changed. There is nothing that the Ubuntu-MATE devs can do about that. There has been a whole discussion about it that you can find here

The other problem is that this URL is hardcoded in the weather-app (actually, in its library libmateweather.so) and not in a config file.

That means that you either need an updated libmateweather.so file
or patch it manually.

Another problem is that 18.04 and 20.04 are no longer supported so there will not be an update of libmateweather.so for neither 18.04 nor 20.04

That leaves manually patching the libmateweather.so as only option.

Manually patching the libmateweather.so is discussed in the earlier mentioned link. You could try that if you feel you're up to it.

If you don't feel comfortable to manually patch that file then the only solution is to disable/uninstall the mate weather app and find a different app to replace it (which I think, reading from another thread, you already did :wink: )

2 Likes

Hi @psfal,

If you find a patch for 20.04 that works I'm looking for same. Anyone? Please let us know.

I know the sed command patch works on 22.04, 23.10 and even Debian 11 with Mate 1.24.1.

But not 20.04 and I tried everything I could think of. I don't have an 18.04 to test but I bet it's the same as 20.04.

2 Likes

Hi, @Bill_MI,

the workaround for Ubuntu MATE 20.04 is to remove the www. part from the new URL string.

If you are explicitly looking for a sed patch, try editing your patch string accordingly (remove www. --> 4 symbols AND append \x0\x0\x0\x0 --> 4 null characters), something like:
sudo sed -i 's|https://www.aviationweather.gov/adds/dataserver_current/httpparam|https://aviationweather.gov/cgi-bin/data/dataserver.php\x0\x0\x0\x0\x0\x0\x0\x0\x0\x0|' /usr/lib/x86_64-linux-gnu/libmateweather.so.1.6.9

I hope this helps

4 Likes

Bingo! Worked like a charm, thanks so much!

3 Likes

You are welcome @Bill_MI !

1 Like

I installed Meteo and it works great.

They may get this weather applet fixed, or they may not. It's no longer an issue for me.

1 Like

Hi @psfal

I looked at it and it is a good substitute. I ran it for awhile.
But I'd rather not add PPAs and the other fix is perfect, now with my custom radar and all.

1 Like