I broke weather applet

are you seeing temperature?

Welcome @egor83 to the community!

Thanks, and thanks for the like as well! :slight_smile:

1 Like

This morning when I responded with my 20.04 desktop I did see temperature. I am now at a different location using 22.04 on a laptop and do not see temperature.

1 Like

The same problem with Ubuntu Mate 22.04.3

1 Like

I found this thread as a work around. Have not tried yet.


Welcome @tchken to the community!

Thank you for the link, Jay. :+1:
I've just now tested it and it works.

For all people who are interested but struggle with the instructions, here are the details of how I followed the steps outlined in Jay's link :

First test if you have the right version of the library,
This is how you are supposed to check it:

sha256sum /usr/lib/x86_64-linux-gnu/libmateweather.so.1.6.9

it should output this checksum:


If they are the same you can download the patch

Unpack the patch.zip to your home folder.
Then use this command to generate a patched libmateweather:

bspatch /usr/lib/x86_64-linux-gnu/libmateweather.so.1.6.9 ~/libmateweather.so.1.6.9 libmateweather.so.1.6.9.patch

( You might have to install bspatch first if the system complains about command not found

sudo apt install bsdiff


then replace the old libmateweather with the new one:

sudo mv -f ~/libmateweather.so.1.6.9 /usr/lib/x86_64-linux-gnu/

Log out and log in again (or reboot) and it's done.

EDIT: Works on 22.04LTS. Also works on 23.04 and 23.10 (tested)


Thanks for checking out and providing detailed installation instructions. Did the trick!


May I presume that if the version is the same(running 23.04) all updates but the sha256 sum is different, the patch is a no go?

I can verify the patch (sed command) works fine on 23.10 but despite the old/new URLs matching perfectly, it doesn't work on old 20.04. Anyone have luck with 20.04?

1 Like

This patch fixed my 22.04 and it showed the weather for several days. But now it doesn't work again.
Tried to replace with a backed up copy. Then tried to patch the backup copy again but all with no luck.

1 Like

Welcome @ryzhik to the community!

Mine is still there.

Exactly ! :slight_smile:
If your sha256sum is different, the patch will pretty much destroy libmateweather, rendering it completely unusable.

1 Like

Yes indeed.

My weatherinfo failed today on my UM 22.04 LTS install

The weird thing is that it is still working on my UM 23.10 install while both UM versions use the exact same libmateweather.

I do not understand this.
If I find something I'll report back


This is a problem across the board with any distros based on Debian or Ubuntu. The source of the problem is the weather Metar people who provide the service. The forecast shows but not the current conditions. The weather METAR people changed their server again. Everytime they change servers this is what happens. It has happened a number of times in the past several years. There's not much that can be done about it at this time. Install the Weather addon by Tim Leland in Firefox. It is quite good and will replace the corrupted MATE weather icon in the panel. Plus it will give weather information for virtually any city/town which the MATE weather does not.


Am alternative to the "MATE Weather" indicator I found very useful - provides almost any location and is not limited to the few available in "MATE Weather" => "Meteo" (got it from here: 5 Best Weather Apps for Ubuntu & Linux Mint - OMG! Ubuntu -> 2.Meteo)

How to install:

sudo add-apt-repository ppa:bitseater/ppa
sudo apt install com.gitlab.bitseater.meteo

After installation you can start the app directly from the menu (search for Meteo).
From the preferences you can choose:

  • Use System Tray Indicator
  • Start minimized
  • Launch on start (or configure Meteo as a Startup application in the Control Center)

I am confused. Still running on 22.04 for me.

I don't know why. Maybe it is region bound ?

No, it's not region bound.
(below maybe also interesting for @ryzhik)
I suspect my install to be the culprit.
Two other (old) computers of mine are also running 22.04 and have no problems with the weather-applet.

I think I might have to do a reinstall of my main rig.