Connecting to wifi not possible: I can't see my wireless network in the list

I recently got a Raspberry PI 3B and i installed Ubuntu MATE 16.04 on it. Everything worked fine and I could connect to my wifi network.

However, after a day or 2 all of a sudden the raspberry didn’t connect to my wifi anymore. My network is not listed in the wireless networks, whereas all other networks around me are still visible. Also, other computers and smartphones have no issues connecting to the wifi. It is just the raspberry.

I tried the following things without any success:

  1. restarted raspberry pi
  2. restarted the router
  3. moved my raspberry pi system closer to the router (I thought it might be out of range)
  4. Reconnected via ‘hidden networks’
  5. Manually connected via terminal
  6. Updateded raspberry via apt-get
  7. Reinstalling ubuntu MATE on the micro sd card

I am fairly new to ubuntu and at the moment I ran out of ideas what might be causing the problem and possible solutions. I searched for solutions in this community and in general online, but I barely found any useful results.

What can be the cause of this issue and how can I fix it?

Hi @Gendow,

take a look here which might help you?:

Hi @Gendow, your description comes closest to what I experienced. Thanks for asking this!

I have used my RPi3 and its built in wireless heavily recently. For a month or so. I noticed that it (the wireless of the pi) doesn’t like the wireless router to be turned off on powering up the raspi at all. Once I turned the raspi on while the wlan was turned off and I couldn’t get it to function this day. Because I was busy I left it to it. Next day it would work again. Without any actions taken. Apart from turning the wireless on first!

Today, it happened again. This time the RPi3 would not “see” the wireless as any other client would. This after doing steps 1 to 4 and 6 via cable. Checked various hints like the one of @wolfman.

Finally, I read and installed this accordingly:
sudo apt-get install wpagui
Where it tells one to be run like this:
You will need to run it via gksudo wpa_gui so that it can talk to the WPA daemon.

Clearly, my router was not visible for the pi. Using wpa_gui I could tell easily as some other networks were. So why couldn’t it?

I wondered why wpa_gui could not list the many more networks which are visible at my place. So I started to scrutinize my wireless routers settings…

I altered the router setting which initally kept the channel of the wireless fixed to channel 13 to automatic. After restarting the wireless router the RPi3 was able to find my network as if by magic.

The automatic selection of the wireless channel worked in my case.


  1. I used wpa_gui just once to check the wireless environment!
  2. Previously, and I am rather sure about this, the “connection information” of MATE was not available or functioning. Never saw this dialog before.

Maybe installing the wpa_gui also fixed something in the background. Anyone any ideas? Or places to check for logs?

1 Like

Hi guys,

Just to give back a bit here. This cost me so much time trying to troubleshoot.

I had a similar issue to above. My RaspberryPi 3 would not list or connect to some Wifi networks I had used previously - but continued to list numerous others.

As alluded to above, I changed the channel on my Wifi device and it displayed and connected successfully again.

1 Like