Control Centre - File Management Preferences

I’ve struggled with something for a while now.

When I insert a blank DVD-R, I get two dialogs opening up:

1 - entitled 'Blank DVD+R DL Disc, says 'You have inserted a blank DVD. Choose what application to launch.
Select how to open “Blank DVD+R DL Disc” and whether to perform this action in the future for other media of type blank DVD disc".
The box to select the application says “No applications found”

2 - Untitled dialog, says “Unable to mount Blank DVD+R DL Disc.Location is already mounted.”

After you click OK on dialog 1 Brasero opens.

I’m not sure why the second dialog is opening.
What I want to happen is to be able to select Brasero as the application to open.

In Control Centre-File Management Preferences-Media it isn’t possible to select any application.


I’ve just found this link, which confirms that the problem was identified in Ubuntu 12.04:

It doesn’t seem to have been fixed yet.

I think I get this too, but I became oblivious to it and close the other window. It’s not that often I use CDs/DVDs these days.

Since we don’t use unity-settings-daemon, the fix would need applying to mate-settings-daemon.

1 Like

Not sure if this is the problem (I don’t have any blank CD/DVD to test), a quick search with dconf-editor show two schema for media-handling and mounting, one for Nautilus and one for Caja. I suspect what is happening is the Gnome/Nautilus one is being run first, so when Caja tries it sees the disk already mounted and spits out an error.

If you open dconf-editor (you many have to install it if it’s not on your system) and go to org/gnome/desktop/media-handling you’ll see the one set for Nautilus. Under org/mate/desktop/media-handling is the one for Caja. Again I haven’t been able to test it myself, but I’m thinking if you disable the one for Gnome/Nautilus it will cure the error message.

I’ll try that later tonight and let you know. Thanks for the suggestion @folcred

OK. I tried a few things there and had partial success.

First, in org/gnome/desktop/media-handling I turned off both ‘automount’ and ‘automount-open’. I left the other options as they were. I came out of dconf-editor and inserted a blank DVD+R.
The same thing happened. Both dialogs opened as I described in my earlier post. When I closed dialog 1 (see earlier post), Brasero opens.

I relaunched dconf-editor and in org/mate/desktop/media-settings I also turned off ‘automount’ and ‘automount-open’, leaving the other options as they were.

Reinserting a blank DVD+R, only brought up dialog 1, which when closed opened Brasero.

So, partial success.

I will play with the other options later and report back.

That seems a bit odd that it’s still mounting disks with both turned off. I’m running 16.04, and a look in /etc/fstab shows nothing on my system that would mount CD/DVD disks. Makes me wonder what’s mounting them. Something in systemd or some other global utility?

I’d be curious if, with both turned off, it still mounts with the single dialog after a log-out log-in, or reboot.

There’s nothing in my /etc/fstab that would mount DVDs.

Yes it still mounts with the single dialog after a login and a reboot.

Did some searching, seems you need to associate a mime-type for blank CD/DVDs in order to get Brasero to open by default. Don’t know why there’s no option somewhere in the file manager or settings for it. Anyway, I found this on the Linux Mint forums, I would think it will work with Ubuntu MATE too. It involves just adding a couple lines to the user’s mimeapps.list file in ~/.local/share/applications/

I found a few others googling, but this seemed the simplest solution. Hope it helps.

1 Like

The optical media associations were fixed in Ubuntu MATE 16.04 beta 2 :slight_smile:


That’s excellent news! :joy: