Copy files to USB in Caja stops at 100 percent. Caja “freezes”

system

#1

The following should be the standard configuration in Ubuntu MATE, because the average user is likely to lose data and will think there is a bug in linux, because the progress bar “freezes” and s/he will try to remove the USB stick before the copy process has ended.

The following is a well-known situation on linux systems:
“When i try to copy something to USB stick, with FAT, it stops near the end, sometimes at 100%. And of course, when i transfer the memory stick somewhere else, it doesn’t contain complete file. (file is a movie!)”

Work-around Solution:
sudo pluma /etc/sysctl.conf
go to the bottom of the file and paste this line:
vm.dirty_bytes=15000000
Save file.

Explanation:
“The reason it happens that way is that the program says “write this data” and the linux kernel copies it into a memory buffer that is queued to go to disk, and then says “ok, done”. So the program thinks it has copied everything. Then the program closes the file, but suddenly the kernel makes it wait while that buffer is pushed out to disk.

So, unfortunately the program can’t tell you how long it will take to flush the buffer because it doesn’t know.”

The above configuration forces the kernel to flush data to the disk after every 15 MB, so caja can update its progress bar state.

Please vote this matter up. It is quite basic and easily solved, but a pain for the average user if left unsolved.


Safe to remove USB device?
#2

Seems to be related to my question on AskUbuntu Strange LED blinking problem with USB flash drives - is it just me?.

I solved it by buying great ADATA UE700 flash drive.

I do not need any changes in the configuration files with it. It stops writing almost immediately and LED indicates that it had finished.

Linux is not main problem. The real problem is bad cheap low-quality modern USB flashes.


#3

No, that does not hold water as an argument. If the majority of USB devices work without a problem on other OS’s but have a significant problem when used on Linux, it is a weak argument to suggest it is the UBS manufacturer’s who need to fix the problem. Or, at least, if the only way to get Linux to work is by purchasing only the most expensive hardware, then that is not a good road to go down in the promotion of Linux


#4

I used to have problems with that before 18.04, but don’t seem to anymore, (if I do is so rarely I don’t notice it),occasionally it seems to hang but if you wait it finishes