Copy-paste not working properly in Caja

When I copy a file it does not allow me to paste it until I have copied it twice. No difference if using right-click menu, edit menu on the top or ctrl+c. So if I want to copy a file I need to press ctrl+c twice and then I can paste it elsewhere. No matter which partition the file is located and reboot does not solve the problem. Any ideas?

Caja 1.12.17
Ubuntu MATE 16.04.2 LTS

I can not reproduce this behavior in 16.04.2 LTS w/ Caja 1.12.7-1

That is odd. Have you tried a reinstall? Maybe remove the config file and purge it.

rm ~/.config/caja && sudo apt purge caja && sudo apt install caja mate-desktop-environment-core ubuntu-mate-core

Thank you for the replies!

To make the story short I figured out that this is somehow related to KeePass2 password manager and not Caja. I noticed that ctrl+c worked funny in LibreOffice Calc too (ctrl+c did not copy the formula which is the default, but two times ctrl+c did).

Seems like Caja and LibreOffice works just fine until I open KeePass2 and copy one password from there. If I close KeePass2 it’s fine again. Maybe I should try to downgrade KeePass2 because I don’t remember having this problem before and been using that manager for years. Seems like others are having problemsm too

Edit: Downgraded to 2.32 and now everything is fine. :relieved: