Could not acquire name on session bus

I have XRDP installed on my Raspi 4b, Ubuntu Mate 20.1, I am able to login with Windows 10 using RDP, and even see the Welcome screen and issue commands. However, immediately after connecting, I get this message, "Could not acquire name on session bus." I am unable to see the desktop background, as its completely black.

Hi there @AviatorSS.

I looked at this as I encountered this same error with Chrome Remote Desktop when I was running Ubuntu-Mate 18.04 LTS. However, the solution to this error with XRDP appears to be a little different.

It seems that someone has encountered the exact same issue as you as posted here -

Just to confirm though, I haven't tried this myself.

By the way, the solution for me with the Chrome Remote Desktop issue was to add a config file in the home directory named .chrome-remote-desktop-session and containing the lines


I cannot remember where I found that solution, but it worked for the Chrome Remote Desktop problem.


I had the same issue as @AviatorSS. Solved it using your post.

I added those 3 lines to ~/.xsession and restarted xrdp.

Now I can login with the same account also via RDP, thanks a lot for the help.


I have the same problem that seems to be linked to Google Remote desktop. black screen. Could not acquire name on session bus.

Thanks very much... works¡¡¡¡:slight_smile:

1 Like

@alexdelprete suggestion worked perfectly for remoting using Chrome Remote Desktop -- I now have Ubuntu 20.04 MATE serving an old Acer chromebook client. The latter is using the Chrome remote desktop browser extension. The change solved two problems I was having. The DBUS error is gone, and my session is automatically scaled to the display resolution of the chromebook. Thank you!

Good to see the solution I posted in this thread still works more than a year later :grin: