Could not find fallback terminal emulator application

Could someone help me with this ?


Hi, @fixit7 (Andy) :slight_smile:

You wrote:

So, it seems that you're using the "Thunar" file manager ("Thunar is a modern file manager for the Xfce Desktop Environment" - instead of using "Caja" ("Caja is the default file manager for the MATE Desktop Environment." -

I've never used "Thunar" but, according to the following discussion topic that you started here, in the "Ubuntu MATE Community", back in 2018:

... the solution in that discussion topic, posted by @elcste (Alexander Browne), on 20th July 2018, seems to be to change the command text of the Custom Action for "Open Terminal" so it reads as follows:

mate-terminal --working-directory=%f

Here's the link to that answer by @elcste :

There's a video in YouTube that illustrates the procedure in "Thunar", but it is for Debian (and not for Ubuntu MATE) and it's for setting the terminal app for "terminator" instead of "mate-terminal". Even so, I'm putting here the link to that video because the procedure is quite similar:

So, for your case (@fixit7), it seems that, in Thunar, you should go to "Edit" menu -> " Configure Custom actions..." -> " highlight "Open Terminal" and change the configured action so it reads as follows:

mate-terminal --working-directory=%f

I hope this helps :slight_smile: Please, reply later in this same discussion topic to tell us if this worked for you or not.


Thank you so much.

It worked. :slight_smile: