CPU throttling When power cord plugged in, now no charge

uname -a
Linux Bessy 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Ubuntu-mate 18.04 on a Dell Latitude 3580.

This post is related to:


I didn't put this in the hardware part because I'm 100% sure it isn't the hardware.

So I was having issues with processes using too much CPU. It's an intermittent problem. I installed the cpu frequency panel applet a few days ago and just today the laptop slowed down again drastically. The CPU is throttled between 400 and 750 Mhz. It will not go above that speed and I've tried a lot of suggestions online. When I simply set the governor to performance I get no improvement.

I can't find any info online that's really useful. I need to be able to use tlp and whatnot to extend battery life so I can't delete that or just set the CPU to performance and leave it there. Setting it to performance isn't helpful anyway.

The thermals are all fine. I tried an MX-Linux liveUSB I had laying around and the performance was fine.

I'm pretty stumped. If you need any other info please let me know


I found out the throttling only happens when the charger is plugged in. When it's unplugged the frequency scaling goes back to normal

especially the last section

The MX-Linux kernel probably has different compile options than the Ubuntu kernel.



I still have to go through the wiki entry but after a reboot things are back to normal. This seems to be an intermittent problem. Any help pinning it down would be appreciated.

EDIT: Laptop came back from suspend and CPU is stuck at less than 800 Mhz despite using the advice in the Arch wiki entry. Rebooted, Cpu still throttled

Intel P-State throttling document from Intel describing what Intel’s new kernel code does.

I’m not that familiar with newer Intel CPUs:(

The following note in the above doc is concerning:

The CPU can throttle itself?!?

The doc describes some sysfs files that may show what is going on. There are also some hints at diags and tuning.

The Intel doc gives me a headache and glossy eyes! The best option to try first is probably the kernel option:


I have no experience or idea how to proceed from there.


1 Like

As soon as I can wrap my head around the doc I’ll try some things. I appreciate the help


It seems the CPU gets throttled when the power is plugged in. As soon as I disconnect the AC adaptor, the frequency is normal. As soon as I plug the power back in the CPU goes back to being capped at <800Mhz

I have a really hard time understanding the documents you’ve given me and I don’t really see how most of it can be applied. This isn’t an attack; It’s just a little over my head. I can’t find any info on this phenomenon. anywhere else

Also the battery indicator is giving wildly inaccurate readings. 27 hours is a bit of a stretch for a laptop battery.

Ok, I’m stupid. I thought I had passed the parameter


to the kernel but I forgot to. I just did and everything is fine now :slight_smile:

It sure looks like the ACPI tables are suspect.

Looks like the latest BIOS from Dell is 1.10.1 and was released in Dec 2018. A BIOS update may fix things.

If it is an issue in the Intel PSTATE driver in Linux then a later kernel may fix things too.

Slowing down when plugged in is opposite of what I would expect.

Lets hope the kernel setting fixes the slowdown as BIOS updates have become a pain nowadays.


Sorry to resurrect this old thread. I'm trying to do a BIOS update from the software center but I'm getting an error saying the laptop needs to be plugged in. It is, the indicator on the taskbar indicates AC power but it's not charging. I've had it plugged in for over 2 hours with both the laptop on and turned off and the level hasn't changed at all. I haven't fiddled with any settings in the BIOS. I looked in the BIOS and it showed the same lack of charging. Both the taskbar indicator and the BIOS show the same level of charge. I'm using a non-Dell charger but i have been for over a year without a problem. I checked it with a multimeter and it seems fine.

EDIT: So I upgraded to the 4.18 kernel and the CPU throttling issue went away... for now.... I still can't update the firmware and the battery still isn't charging