Critical issue after full-upgrade

I'm surprised that this is marked "not release critical". Sure, in the absolute sense, one can install the OS successfully. But if an update appears the next day, then the OS is going to get borked by the removal of required system packages. Obviously not desirable.

I wanted to repeat what I said in my earlier message in this discussion. The talk seems to focus on dist-upgrade. However, I was just doing a routine update via Update Manager, and encountered this problem. So the problem is much more pervasive than dist-upgrade. It will affect everyone doing any type of update.

1 Like

Easy to reproduce the issue about FULL-UPGRADE:

  • Install 22.04.1
  • Manually upgrade upto the 3th August 2023
  • Reboot
  • Then wipe the system with sudo apt full-upgrade

I have successfully restored my system to a backup. Latest backup I had was 6 months old :pensive: Learned my lesson to backup more frequently.

I now want to bring this system up to a date before this problem occurred on August 4, 2023. I don't see an option in apt to limit updates to a latest date, e.g., apply all updates on or before August 1, 2023. Is this possible?


1 Like

I would just apply a full-upgrade, and even if some essential packages get removed (aka bug) the metapackages can be re-installed in a second or two. I wrote about it here as I let the damage occur on my primary box (to confirm it would be easy to fix).

If I'd suffered the damage you described earlier, I'd likely have done a non-destructive re-install too; as I re-install some of my systems weekly instead of performing normal package upgrades as it achieves the package upgrade (I use daily ISOs and not released images) at the same time accomplishing a QA-test of the newer daily ISO.

Do note the non-destructive re-install is great where no third party packages are involved, OR specific ones built to be 'future proof' are involved, but experiences can differ depending on what third-party packages are used; if you're not familiar with what I'm describing you can look at an answer I wrote here


I just updated an Ubuntu MATE VM, which is separate from the native install I discussed earlier in this discussion. The update of the VM installation completed without issue - nothing got deleted. I'm typing this on Friday, August 10, 2023, so I'm concluding that something got fixed to address this problem. I'm going to wait a little longer to try an update on the native install that I just recovered. I'd like to avoid repeating messing it up.

1 Like

Thanks a lot for your tests and further analysis!

I provided a link to where I talked about the issue, later in that thread I mentioned

Hopefully though, you're correct, in the that issue has been fixed. :slight_smile:

Alas the message from Julian Andres Klode on the bug report comment #16

refer currently to a package only in -proposed.

 apt | 2.4.9           | jammy-updates   | source, amd64, arm64, armhf, i386, ppc64el, riscv64, s390x
 apt | 2.4.10          | jammy-proposed  | source, amd64, arm64, armhf, i386, ppc64el, riscv64, s390x

but maybe I'm wrong, regardless we'll get there :slight_smile:


Hello just updating my situation not totally related to above. At time I installed UM22.04.2 via usb (not aware that .3 was in progress) and ended up with upgrading something like 148 pkgs.. Then no updates were showing in GUI upgrader. Did another install with same usb and this time only 2 .dap upgrades were held back. This was on 08 Aug 2023. Then every day checking with GUI updater Computer is up to date. Well today 13 Aug 2023 updater pointed out two ( the dap that were held back). Think my issue was related to items here:
Clumsily initally upgraded all those packages. Checking on the two *dap in latest installation on what would happen if I removed them it would have wiped most of my system.
Just update (of what I found)edit

Last Saturday, it was the first time ever I tried to run full-upgrade command. It was on a 10ys old wife's computer running Ubuntu MATE 22.04, wiping core packages and destroying the system :joy: Because it was totally unexpected, I really did not know what to do. So I took advantage of the situation and bought a new SSD, removed the old slow HDD and reinstalled the system. Now the computer is much more usable, so thank you for this issue :stuck_out_tongue_winking_eye:


Welcome @ratatoskr to the community!

1 Like

After one week since my first alert, back at home. Good news, the issue about full-upgrade is gone. Last week, a simulation with full-upgrade will wipe the system. Today, same simulation on same system, nothing will be wipe. On the other hand, I don't understand why main stream sites about Ubuntu didn't communicate about this issue, for example, tell to people to not update.


Hopefully final update from me on this issue. I finally decided to upgrade my Ubuntu MATE bootable installation on my primary system; because of this issue, I was cautious to do a dry-run first, and ensure that nothing was going to be deleted. I'm happy to report that it succeeded with no issues. It did hold back about 8 packages. I searched about these hold backs, and found suggestions to just be patient, that these hold backs are a result of phased updates.

Today, I did another update, and 6 of the 8 where upgraded. So, I'm going to take a backup, and assume this issue is resolved. My thanks to all who provided assistance and guidance here.


Thanks for the follow-up replies @guyr and @Philippe :slight_smile: I'm happy that your Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") installations are "back on track", but I believe that the issue will only be really "solved" (prevented from happening again) when the "apt" package eventually gets updated from version 2.4.9 to 2.4.10 that is supposed to fix the following Bugs:

From the current content of the web page "UbuntuUpdates - Package "apt" (jammy 22.04)" - - here is the "Changelog" for the version "2.4.10" of the "apt" software package:

" (...)


Version: 2.4.10 2023-08-03 21:07:03 UTC
apt (2.4.10) jammy; urgency=medium

  • dist-upgrade: Revert phased updates using keeps only (LP: #2025462)
  • Do not mark updates for install that are still phasing (same bug)
  • Compare SHA256 to check if versions are really the same (Closes: #931175)
    (LP: #2029268)

-- Julian Andres Klode Wed, 02 Aug 2023 15:15:58 +0200

2025462 Apt deletes ubuntu-desktop during dist-upgrade
2029268 Do not consider two versions with differing SHA256 to be the same
931175 Include hashsums when comparing packages from different sources


I noticed that the package had been released (email as I was an impacted user to the bug report)

The verification of the Stable Release Update for apt has completed successfully and the package is now being released to -updates.

A quick CLI command confirms it

apt | 2.4.5           | jammy           | source, amd64, arm64, armhf, i386, ppc64el, riscv64, s390x
apt | 2.4.10          | jammy-proposed  | source, amd64, arm64, armhf, i386, ppc64el, riscv64, s390x
apt | 2.4.10          | jammy-updates   | source, amd64, arm64, armhf, i386, ppc64el, riscv64, s390x

so if using the main archive, OR an up-to-date mirror, us end-users should feel safe (once we've updated of course).