CUPS error when installing Canon MG5622 / Mate 19.10

I have never had an issue with printing wireless. Error occurred after an update. I am not sure of exact date as I don't print that often. The printer is seen, the job gets sent, but does not print.
The printer works when connected with a USB cable. The unit will scan wirelessly! I have tried various fixes listed in the forums with no luck.
I would appreciate any assistance. Thanks in advance. Vince

Hello VinceC

I have just been through a printer-install process with a Brother network printer. I do not use wireless, but have a cable home network instead.
I could not get the printer to work. Someone I know went through the router and printer network configuration with me. A single digit in a network address was incorrect. Afterwards the printer worked. :slightly_smiling_face:
Can you get anyone to go through you wireless networking details with you? My guess is that it could be a network-configuration problem.

Hello alpinejohn. I will check that out. Thanks for your reply. VinceC

I spent a combined couple of hours searching out the possible causes of this issue. I finally decided to a reinstall using my original 18.04 ISO. The pc runs great and now prints using wifi.
Somewhere in the updates of 18.10 something gets changed and causes the CUPS-SERVER-ERROR. Although I won't be the noob who goes running back to Windoze, I don't care to waste anymore of my time searching out the changes or the bug that's causing this error.
I wish to thank all who have the skills and the time who do put forth the effort. I will continue to support the project.
Cheers! Vince

I have run into this same CUPS SERVER ISSUE again after updating my Ubuntu Mate to version 20.04 last week. See screenshot above.
My printer will not print wirelessly after the update. This happens with both my Canon and my new Epson ET-2720.
Whatever was updated in version 19.10 last year and 20.04 this year has had the same effect on my wireless printing.
My solution was to save my files and reload Mate 18.04.5. Wireless printing has been restored. My laptop is an HP dv-7. See below. I f anyone else runs across this issue please share your findings. Thanks, Vince[date=2020-10-23 timezone="America/Phoenix"]System

Follow up:
I have researched this CUPS Server issue enough to give up trying to fix it. I don't have a lot of time to waste on this but I did put a good solid weekend into research and attempting multiple repairs/driver installs/terminal commands found in the forums and Internet searches. Much has been written and many fixes offered to address this issue. It seems this issue varies with hardware, drivers and/or whatever was changed after version 18.04. This CUPS server issue occurs with both my Canon MG and Epson ET-2720 with or without manufacturer Linux drivers installed. I have experienced this with 2 laptops. An HP dv-7 and an Asus Z84J after I upgrade Mate to version 20.04 .
I wiped the drive on this Asus Z84J and installed Mint, Tricia. I am happy to report everything works perfectly. That said, I am going to go with Mint on this particular laptop. If anyone finds a solution, that really works, please share. I appreciate the efforts of all the folks that work to make Mate better and better...I just can't spare the time. Thank you.
Cheers! Vince

I installed 1804.5 on this t620 with no problems. It works great, loaded my Epson ET-2720 printer wirelessly with no issues and no additional drivers.
I installed 20.04 on the same unit. PROBLEM: The same printer is recognized and installed, however when I hit APPLY, I get the CUPS error listed above. Can anyone offer any assistance or advice. I have tried the Linux drivers from the Epson site. I have gone to the CUPS site, followed the directions, all to no avail. Does anyone know what was changed in UM after 1804.5 regarding how printers are installed by the OS? This printer problem happens with any update after 1804.5 on multiple PC's and Laptops I have tested. Cheers, Vince

UPDATE: After months of not using this machine (HP-dv7 and Epson ET-2720), I put my MacBook Pro aside to upgrade my HP from 18.04.5 to 20.04. I'm happy to report I was able to install my printer wirelessley with no problem at all.
I did a fresh install on a new ssd drive. I used a DVD I made from a 20.04.2 ISO back in April. I connected an Ethernet cable, unchecked the boxes for "third party " and "updates" during install.
Upon completion, I let the updates run. Then I installed the latest drivers from the Epson site. I now unplugged the Ethernet cable and connected to my WiFi.
Next I opened "Add Printer". Under "Network Printer" I chose the Epson ET-2720 (192.168.X.XX) . On the next column under connection, I chose LPD/LPR queue 'PASSTHRU'.I noticed the Host was the IP number with an additional (:515) added to the IP
Next I hit Forward. On the next page the name of my printer was listed Under both PRINTER
and Description. The location was the IP numbers. Next I hit APPLY and the printer was added with the box asking if I wanted to print a test page. The printer works perfectly.

1 Like

Hello VinceC

Thank you for the detailed description of what worked. Someone else will sooner or later hit be hit by a similar problem that this will help them solve. :slightly_smiling_face:

Hello again and thanks for your reply. I also installed 20.04 on a (mid 2011) 27" iMac that no longer supports an OS past Sierra. This i7 Intel machine runs UM perfectly!

Cheers, VinceC