Deb-get not working after upgrade to Ubuntu 24.04

I upgraded from Ubuntu22.04 to Ubuntu24.04 -- but the useful "wimpsworld" app, deb-get no longer works.


sudo deb-get install zoom dropbox fails, with an error message that Ubuntu 24.04 is not supported, since it is not an authorized Debian or Ubuntu OS.


1 Like

Welcome @lubkin to the community!

Hi, @lubkin :slight_smile:

You wrote:

I don't use "deb-get" - GitHub - wimpysworld/deb-get: apt-get for .debs published via GitHub or direct download 📦 - - which indeed is a open source tool (MIT License) created by @Wimpy (Martin Wimpress) himself, but I've found a closed issue / bug in the GitHub Repository - - that was reported by the user TiLopes on 29th February 2024:

In that bug, the user "dacorsa" wrote the following comment with a solution that apparently works (according to a comment written in that issue by user "cst-rmrz"):

Cannot install deb-get on Ubuntu 24.04 (I'm using WSL though that should not make any difference) · Issue #1029 · wimpysworld/deb-get · GitHub

you have to install in this way:

cd /app
git clone
cd /app/deb-get/
git reset --hard
git pull
cd /app/deb-get/docs/
ls -la /usr/bin/deb-get*
make install
ls -la /usr/bin/deb-get*

So, @lubkin, I suggest that you try the above suggestion and hopefully it will also work for you. Please, report back later, in this discussion topic, to tell us if it did work or not, as it can also be useful for other users of "deb-get" in Ubuntu MATE 24.04 LTS ("Noble Numbat") :slight_smile:


already tried that -- thoroughly failed.

I've even done a fresh installation of deb-get -- it installed without trouble; but refuses to work on Ubuntu 24.04.

My guess: wimpysworld hasn't yet made deb-get available to 24.04 yet. Although 24.04 has been released, I couldn't go directy to 22.04 yet -- i had to first go to 23.10 (I think that's the right version), and then to 24.04. You can't do it yet directly from 22.04. My guess: that will happen by August -- and by then, deb-get will be happy with 24.04.

Hi again, @lubkin :slight_smile:

You wrote:

"(...) My guess: wimpysworld hasn't yet made deb-get available to 24.04 yet. (...)"

I've browsed "deb-get" current source code just now in the GitHub repository and I found that it already covers the "24.04" release of Ubuntu ("noble") in the file (bash shell script) that is also called "deb-get" - "deb-get/deb-get at main · wimpysworld/deb-get · GitHub" -

Let me quote here the relevant part of the source code of that file - please note the noble) UPSTREAM_RELEASE="24.04";; line in following code excerpt from that file:

   buster)   UPSTREAM_RELEASE="10";;
   bullseye) UPSTREAM_RELEASE="11";;
   bookworm) UPSTREAM_RELEASE="12";;
   trixie)   UPSTREAM_CODENAME="13";;
   sid)      UPSTREAM_RELEASE="unstable";;
   focal)    UPSTREAM_RELEASE="20.04";;
   jammy)    UPSTREAM_RELEASE="22.04";;
   kinetic)  UPSTREAM_RELEASE="22.10";;
   lunar)    UPSTREAM_RELEASE="23.04";;
   mantic)   UPSTREAM_RELEASE="23.10";;
   noble)    UPSTREAM_RELEASE="24.04";;
   *) fancy_message fatal "${OS_ID_PRETTY} ${OS_CODENAME^} is not supported because it is not derived from a supported Debian or Ubuntu release.";;

Are you sure that you're using the "deb-get" latest source code that is currently available in the GitHub repository and not an older version that you had installed in Ubuntu MATE 23.10 (prior to the upgrade you've done to Ubuntu MATE 24.04)? Maybe you have both versions of "deb-get" installed in your computer and the path in your system is still pointing to the older one?


I'm new to linux. I'm running Ubuntu 24.04 LTS. It is a fresh install. I am having the same problem. I tried to install amdgpu-install_6.0.60002-1_all.deb and deb-get_0.4.0-1_all.deb with a sudo install. I used sudo apt install curl lsb-release wget
curl -sL | sudo -E bash -s install deb-get and sudo apt-get install ./path/to/deb-get_.deb. I'm running into the same error. Is there anything that you could recommend so I could install deb-get using the source code?

1 Like

Welcome @George_Pakhlavuni to the community!

Hi Ricmarques!

Yes; I downloaded the shell script; I call it That shell script works great: E.g., the command "sudo \bin\bash install zoom" works perfectly. but, so far, to the best of my knowledge, the current executable file deb-get does not support Ubuntu Noble.

-- Saul


Hi, @lubkin!

You have access to deb-get source code (shell script) and releases as .deb packages. The shell script was updated recently, the latest release is dated Nov 9, 2023. Apparently, this release chronologically can not support Ubuntu 24.04, it is too old.
You have several options:

  1. Use a newer script from the source tree.
  2. Wait for a newer .deb release.
  3. Modify the script file from your current .deb package. I believe it was installed to /usr/bin/deb-get. Do it if you understand what you are doing.

I downloaded the shell script previously; it's the same script. I've had no trouble using the shell script. But I don't have source code that will compile to a .deb executable file. (I'm simply using the shell script with bash.)

-- Saul

Inspect your /usr/bin/deb-get file. It is not a binary file, it is a shell script. You don't have to compile anything.


Hmmm.. I downloaded the shell script previously -- I call it The command:
/bin/bash install zoom
Works great. The shell script in my /usr/bin/deb.get does not.

I imagine a .deb executable file called deb.get that works on Ubuntu 24.04 will eventually become downloadable. I can get the most recent such file by executing
/bin/bash install deb-get
When I do that now, I get
[+] deb-get_0.4.0-1_all.deb is up to date.:
If I try deb-get install deb-get
I get!] ERROR! Ubuntu Noble is not supported because it is not derived from a supported Debian or Ubuntu release.

I see! deb.get is NOT a binary executable; it's an executable shell script.
About a month ago, I downloaded the then most recent shell script being worked on by contributors to wimpsworld.
It works perfectly; no error messages complaining about "Ubuntu Noble not being available". I've been using it.
So I'll simply keep using it.
When wimpysworld releases an official version of deb-get that works on Ubuntu24.04, I'll use that instead.
-- Saul


You have at least two versions of deb-get script in your system:

  1. A new one supporting Ubuntu 24.04, you downloaded it manually and named .
  2. The old one from deb-get_0.4.0-1_all.deb package. This one is installed as /usr/bin/deb-get and does not support Ubuntu 24.04.

Here, you are using the newer deb-get script, so it works.

Here, you are using the newer deb-get script to download the latest deb-get_0.4.0-1_all.deb release. Your command works, it installs deb-get_0.4.0-1_all.deb package. During installation, the OLD deb-get script from the .deb package is installed to /usr/bin/deb-get.

Here, you are using the script from /usr/bin/deb-get directly. It's the old one, so it doesn't work. If you want this method to work, you need to replace the script in /usr/bin/deb-get with a new one.