Decent Graphics Cards? rx550 black screen

I have a AMD RX 550 OC 2GB that used to work with 20.04 in legacy, after I updated as many will easily has become a catastrophic ordeal. Nothing I have tried from AMD, downgrading AMD files, NOT using amdgpu-pro, Mesa, anything. I am giving up. The built in drivers will not work........I am currently using the Rv630 a backup card just so I can run Ubuntu.

What is a decent graphics card, or cards, that others are using currently in Jammy LTS??? I do NOT want to go out and run into this problem again. I really only need 4GB to work in both Windows and Ubuntu, this is why I have it. I run Train Simulator World 2020 4gb recommended.

Do you find Nividia Better than AMD?? Tell me what are your thoughts please!!!

inxi -Fxxxrz
Kernel: 6.5.0-28-generic x86_64 bits: 64 compiler: N/A Desktop: MATE 1.26.0
info: mate-panel wm: marco 1.26.0 vt: 7 dm: LightDM 1.30.0
Distro: Ubuntu 22.04.4 LTS (Jammy Jellyfish)
Type: Unknown System: Apple product: MacPro3,1 v: 1.0 serial:
Chassis: type: 2 v: Mac-F42C88C8 serial:
Mobo: Apple model: Mac-F42C88C8 v: Proto1 serial: N/A UEFI: Apple
v: MP31.88Z.006C.B05.0802291410 date: 02/29/08
Info: 2x 4-core model: Intel Xeon E5462 bits: 64 type: MCP SMP
smt: arch: Core Yorkfield rev: 6 cache:
L1: 2x 256 KiB (512 KiB) L2: 2x 12 MiB (24 MiB)
Speed (MHz): avg: 2400 min/max: 2400/2800 volts: 1.6 V ext-clock: 400 MHz
cores: 1: 2400 2: 2400 3: 2400 4: 2400 5: 2400 6: 2400 7: 2400 8: 2400
bogomips: 44691
Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx
Device-1: AMD RV630 XT [Radeon HD 2600 XT] vendor: Apple driver: radeon
v: kernel pcie: speed: 5 GT/s lanes: 16 ports: active: DVI-I-2
empty: DIN-1,DVI-I-1 bus-ID: 02:00.0 chip-ID: 1002:9588 class-ID: 0300
Display: x11 server: X.Org v: compositor: marco v: 1.26.0
driver: X: loaded: ati,radeon unloaded: fbdev,modesetting,vesa gpu: radeon
display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4")
s-diag: 485mm (19.1")
Monitor-1: DVI-1 mapped: DVI-I-2 model: Acer S201HL serial:
res: 1600x900 hz: 60 dpi: 92 size: 443x249mm (17.4x9.8") diag: 508mm (20")
modes: max: 1600x900 min: 720x400
OpenGL: renderer: AMD RV630 (DRM 2.50.0 / 6.5.0-28-generic LLVM 15.0.0)
v: 3.3 Mesa 22.3.0-devel compat-v: 3.0 direct render: Yes
Device-1: Intel 631xESB/632xESB High Definition Audio driver: snd_hda_intel
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:269a class-ID: 0403
Sound Server-1: ALSA v: k6.5.0-28-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
Processes: 272 Uptime: 35m wakeups: 0 Memory: 13.64 GiB
used: 1.68 GiB (12.3%) Init: systemd v: 249 runlevel: 5 Compilers:
gcc: 11.4.0 alt: 11/12 Shell: Bash (su) v: 5.1.16 running-in: mate-terminal
inxi: 3.3.13

I had no problems with any of my AMD chipsets when updating from 20.04 to 22.04. What do you mean by "in Legacy" ?

Don't go around changing drivers willy nilly like a nVidia or MS-windows user, that's pointless.

All drivers are already in the kernel and work like a charm. You probably have a showstopper elsewhere in your system. You may have borked your upgrade, your EFI or your hardware.

Insert the RX 550 again and boot from USB (22.04 installer) into a live session.
If that doesn't work, you have a hardware problem.

Other way to check is to boot and login remotely via ssh and run:

lspci |grep VGA

You should see something like this (ofcourse a bit different depending on your model):

2d:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev ef)

If you don't see that then either your hardware is defect or not (properly) connected.

If you do see a line like that, try the live USB or a complete reinstall from scratch because your upgrade to 22.04 might have gone terribly wrong.

inxi -Gxxxz

  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel pcie: speed: 8 GT/s lanes: 16
    ports: active: DVI-D-1 empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 2d:00.0
    chip-ID: 1002:67df class-ID: 0300
  Display: x11 server: X.Org v: compositor: marco v: 1.26.0
    driver: X: loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa gpu: amdgpu
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: DVI-D-0 mapped: DVI-D-1 model: Samsung SA300/SA350
    serial: <filter> res: 1920x1080 hz: 60 dpi: 94 size: 521x293mm (20.5x11.5")
    diag: 598mm (23.5") modes: max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 570 Series (polaris10 LLVM 15.0.7 DRM
    3.54 6.5.0-28-generic)
    v: 4.6 Mesa 23.2.1-1ubuntu3.1~22.04.2 direct render: Yes

Not anymore. Not since AMD has open-sourced their drivers.

I used to run a nVidia GTX 660 and although it was a reasonably smooth experience, it still had the drawbacks you usually have with proprietary drivers like kernel incompatibilities, version bugs and DKMS problems. A very conservative stance on upgrading made it a lot easier.

When I got my AMD RX 570 all this nagging issues were non-existent. b.t.w. never had any driver problem with whatever AMD chipset after they opensourced everything.

Also the image quality of the RX570 is far superior to the GTX 660.
(even my old fanless HD7750 had better image quality than the GTX 660)

I have several old/ancient desktops and laptops.
Some have nVidia chipsets:
none of these are supported anymore by nVidia drivers.
Some have AMD/Ati chipsets:
all of them are supported by either Radeon or AMDGPU driver.


Thanks for the reply. I will start from the beginning of the issue at hand. I got this card to run the train simulator on windows, not so much for linux . I just want to have 1 card and run windows only for the simulator game, everything else I use ubuntu Mate. I ran into issues with 16 and 18 ubuntu at the time, and upgraded to 20.04 LTS. On all of those I installed it in BIOS mode from CD. I ran into issues and its been years since I fixed it to get it running correctly so I am not so sure on what I had done. Since running an apple product, the 550 is not flashed for the apple screen and I can not select a EFI device from the list to boot/install/liveUSB. Each time I have to take out the card in stick in the RX630 which is problematic. I can however boot with RX550 holding the C key with a CD in and on 22.04.03 and it will go straight to GRUB in 640x480. Nothing more. Will not start up off the CD giving install option list as expected.

When I fresh install in EFI/UEFI the 550 becomes a brick. Does nothing, Black screen of death. The computer will start off the windows drive with HDMI connector. I have no DVI-D to HDMI, just DVI to VGA for the RV630. So to me, the HDMI is working....just nothing with linux. I WAS running 20.04 in BIOS install but it seems when the kernel was updated in 21.04(now running 22.04.04 LTS EFI) this is when the problem happened. kernel 6.2 seems to be the problem?, and looking into it many have seemed to downgrade to kernel 5.1 because of compiling issues with kernel 6.2??.....EFI has no problems what so ever with the RV630 fresh install, when upgraded with AMD offline software amdgpu amdgup-pro(for ubuntu 22.04), the RV630 becomes a screen. This is again a headache. I revert to a fresh install and do all updates, that card is fine.

I have read posts upon posts about radeon drivers, fglrx, RocCm, legacy.....many seem to be having an issue with this card and black screen. Problem is also.....i can not ssh into the computer.....straight from the ethernet jack to my laptop. The computer literally does nothing as long as a drive with linux EFI on it is attached and the RX 550, even if I only have the USB in.....nothing. The computer will only work with the windows drive and the RX 550 in..... As you said, going around throwing multiple installations of the amdgpu software......has done me absolutely nothing but cause more problems. I am at a loss of words on how frustrating this has become.

I did some googlefu and this is, as I suspected, a hardware problem
It is hitting computers with a too old intel CPU so also the APPLE MAC PRO 3,1

Which comes down to this:

you cannot use any newer AMD video cards on the Mac Pro 3,1, as the drivers require SSE4.2, which the Mac Pro 3,1 doesn't support. nVidia cards will work fine, though

But, as you can read in the link above there are workarounds like this:

And this:

You have probably done this before:

So it seems you need this:

Or this:

Or maybe you can upgrade your CPU(s) do a model that supports SSE4.2 ?


Thank you for the research, I don't remember an emulator at all. I remember running into driver problems and finally getting the correct one. I had Tons of notes on this....well, cant find them. I wish I did not update to 21 so I could just look back into what I had done!!!! I still have that system on another hard drive...O'well. Thank you, i get so frustrated, and I really don't remember getting into the Metal Graphics but ONLY I WOULD KNOW 3 years ago!!! I had started with a MacPro 1,1...same series of CPU's though. I will definitely look into these links, I was about to buy a new card and still might....We will see. Time will tell, I shall get back to it when I have time.!!!

I've been reading into the intel SDE. I have fooled with some things, but never this!! If you would be so kind to help me what I think I should need to do here. I have downloaded the package and extracted it. What I understand that needs to be done, is add either the /sde or /sde64 to my init startup script, executing the SDE file to emulate starting at boot.
-Also Disable yama at startup "in init scripts of system".
-Possible nano /etc/modules or nano /etc/init.d......
-deiting /etc/default/grub: "GRUB_CMDLINE_LINUX_DEFAULT" "quiet splash" "add line here"

I fool around here and there, but this is something I have never done as of adding an emulator at startup. Help is much appreciated tkn!!

I have no experience with sse2 emulators so I can not be of much help. I assume that emulating sse2 must be in the form of a kernel module and that it must be loaded before the AMDGPU module is loaded. I have no info how that is supposed to be installed.

However , there is a small chance that the card will more or less work with the Radeon driver instead of the AMDGPU driver. This means blacklisting the AMDGPU module:

No guarantees here ofcourse, but at least it is worth a try.

1 Like

I have checked that, and have deleted amdgpu from my system. There are no amdgpu anymore. The more i think about this, I had originally converted 18-20 LTS to run on my 1,1 for the 32bit efi to run with the 64bit processors. I was running legacy drivers I believe. Upgrading just did not fool with it until 21. I had just swapped HD's from 1,1 to 3,1 so i had the 64efi and 64cpu. Something in that process made this a whole lot easier for I have never even heard of this problem with SSE4,2 being that both processors are from the same family. Also, as of the processors, I can not swap a newer processor that handles SSE4.2 onto this motherboard unfortunately!!! I can just emulate at this point, or get a Pro4,1 dual processor for $200. No graphics card needed. I still have my 1,1 just sitting over here...... I will poke along with what I can find, do not have the extra $200 right now. Thanks

If blacklisting the AMDGPU driver didn't work for you, I have found something else that maybe has a small chance to work.
(it disables a certain part of the build-in AMDGPU driver)

  1. if you have the AMDGPU driver blacklisted, undo it.
  2. boot with the kerneloption amdgpu.dc=0
  3. if this works, add it to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and run sudo update-grub

I don't know if this is the magic bullet but it is at least worth a try,

1 Like