Dedicated video driver not working

Good day ,
I have a Dell Inspiron 3521 with hybrid video card Intel HD4000 and Radeon 8730M dedicated video card. I can't make my system use the dedicated video card it appears as active.
In ubuntu 19.10 i can select to use dedicated video card but in ubuntu mate i can not use this option.How can i activate this option or what command to use when i what to start one game.
For example CS: GO work in frames and i have an I5 processor with 8 GB of RAM so should work smoothly. I've tested it on ubuntu 19.10 and works great.
I've tried until now to install drivers without any success.
Maybe someone can give me another option.

Hi as its been over 12 hours and until you get a better reply
What do you mean by this?

A Were you trying to install some closed source driver or Vulkan or what?

B So what drivers are you using on Ubuntu?

C And if you no longer can get into Ubuntu....what type of driver setup was that?
open source.....closed source......for 2d or 3d

D You could look at the output of your current driver
lspci -nnk | grep -i vga -A3

I have intel onboard graphics so for me....I have i915 and so
dmesg | grep i915 gives some info on firmware.
Yes I know you want to see results for your AMD device
but its a start

I've tried to install the latest available driver from AMD amdgpu-pro-19.30-855429-ubuntu.
and when i install this driver I can not access the computer it gives an error regardingVGA.

Down you can see that my driver appears to use also radeon driver but a have only frames in games and screen tears of screen. The problem is that i can not select what video card to use..maybe there is some command to set up the radeon card as primary?

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
Subsystem: Dell 3rd Gen Core processor Graphics Controller [1028:05b8]
Kernel driver in use: i915
Kernel modules: i915
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M] [1002:6601]
Subsystem: Dell Mars [Radeon HD 8730M] [1028:05b8]
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

was this after you failed to get the UM driver to install and run correctly?

on UM

apt search amdgpu
xserver-xorg-video-amdgpu/eoan 19.0.1-1ubuntu1 amd64
X.Org X server -- AMDGPU display driver

It looks like you may need to read the AMD instructions as you can not expect UM to offer support for a third party software.
will tell you how to check for bugs and report them Altho I am not sure how much support you are going to get there either.

I guess their script....amdgpu-install.....gave you no hints of any install issues when you elected to install the pro variant?

Any how, now that you know I am on intel and you have a third party driver, I will let you decide where to raise your next query.

good luck

Good day,

Yes after i tried that I've tried also from Radeon site.
I've fallowed the correct steps but it still doesn't work.

Thank you for your help i will ask AMD for more support.

1 Like

3 years later be advised that this problem still somewhat exists.

In other words: it is still not very easy to get the amdgpu stack installed on the latest LTS.

In that respect I have opened this thread which is more modern what which hopefully can help you (Given that you have not lost all hope long time ago...) :wink: