[Desktop Environment] Can't enter desktop after switching from "Marco (no compositor)" to Compiz

Hey, I'm in need of help. I'll try to make it straightfoward.

In Mate tweak panel, I changed from "Marco (no compositor)" to something else, to see if I'd get more eye candy.

Immediately after I switched to the other option (I can't just remember the name, probably Compiz), all panels disappeared, then it moved to login screen.

Is there a gsettings command to switch it back? Or delete some bunch of hidden files to 'reset' Mate panel settings?


@candidosobrinho.sa Welcome to the Ubuntu MATE community!

Before we go down the command-line settings rabbit hole, if you can get to the terminal (Ctrl + Alt + Tab) then you can launch
and simply choose the working setting again.
[edit: removed misleading info about Compiz]

Thank you for the reception and response.

I cannot evoke a terminal emulator by Ctrl+Alt+T because I am unable to enter at the MATE desktop environment.

The only way I'm able to do anything is by hitting Ctrl+Alt+F1-6 (since F7 goes back to default desktop manager).

Should I install Xfce or KDE, pick any, run mate-tweak and uninstall? I wonder if there is not a more elegant way of doing this (which wouldnt nerd installing another DE).

gsettings set org.mate.session.required-components windowmanager marco

Should do the trick.

Hey all. Thank you all for the attention.

I was unable to enter the DE by using this:
gsettings set org.mate.session.required-components windowmanager marco

This could take days, so I decided to install xfce4 and run mate-tweak from it. The compositor that crashed was 'Marco (adaptative compositor)', not Compiz (Sorry, compiz!)

Now I'm back to Mate.