Desktop icons, how to get rid of them!

I am new from windows, I like a clean desktop and just use a panel bar at bottom to show what I want. I have worked that out to my satisfaction, however for some reason I cannot ‘delete’ or move the ‘home’ folder icon from the desktop to leave it empty, nor the icon for a connected portable harddrive. (no option on ‘right mouse click’ allows this).

Annoying rather than critical but is there a simple way please?

i did try creating two desktops and a switch it did not work and the damned icons stayed on desktop!

Go to System -> Preferences -> Look & Feel -> MATE Teak
In ‘Desktop’ uncheck ‘Show Desktop Icons’


System, Preferences, Look and Feel, Mate Tweak. On the Desktop Icons tab you can select which types of icons to display or not to display any icons at all.

1 Like

Go to "system/preferences/look and feel/mate tweak" and select "desktop"

Check "show desktop icons"

Un-check all other items below "show desktop icons"


wow, a surfeit of assistance, thank you very much, done!

Make sure you still have “show desktop items” checked. But, un-check the other items below it. The reason for this is that is that if you un-check “show desktop icons” you will also lose your right-click context menu functionality when using the desktop


thanks, i use ‘context’ menu a lot.

1 Like

I moved the solution flag over to @stevecook172001’s answer since it matches @morgan’s requirement more closely.

1 Like

Is this a bug or a feature? Seems to be inappropriate.

It’s neither. It’s just a bit of semantics that has been overlooked, in my opinion. That is to say, it would be better if, instead of “show desktop icons”, it said something like “manage desktop”. Because that is what it really means.

Thus, it is possible to have:

A) A managed desktop (including things like personal icons and context menus) with some, all or no system icons

B) An unmanaged desktop which will also not have, by definition, any system icons.

1 Like

Good answer! It should read “manage desktop”.

My conkys disappeared when unchecking “Show Desktop Icons” but I discovered that that was due more to a conky issue. Thanks Steve.

None of these solutions works here. I’ve checked and unchecked ‘Show desktop icons’ with and without the other options below it and I still have no desktop icons. I should have two files and maybe one or two mounted disks.