Diagonal bars when trying to rotate screen

I am trying to use a vertical screen for a project and was having issues rotating the display. The gui for the display did not recognize my monitor at all, so I can't rotate it there. I had to set my resolution in /boot/firmware/usercfg.txt.

Then, I tried using xrandr -o left and received the following error.
Edit: Every time I run xrandr, I get the following error too xrandr: Failed to get size of gamma for output default

X Error of failed request: BadMatch(invalid parameter attributes)
    Major opcode of failed request:      140 (RANDR)
    Minor opcode of failed request:      2 (RRSetScreenConfig)
    Serial number of failed request:      14
    Current serial number in output stream:     14

Since this didn't work, I saw that I could rotate it by changing display_rotate in /boot/firmware/usercfg.txt to =3. When I did that and restarted, the display was in diagonal stripes (see images). I could see movement in it and programs opened up, but it's obviously not exactly what I'm looking for.

Can anyone help me either use another way to rotate the screen or help me fix one of these problems? Thanks for your help in advance.

I am using a Raspberry Pi 3B V1.2 if that matters.

I fixed it!:confetti_ball::tada::tada::confetti_ball:... kinda. I got something to work.

I had set my hdmi_mode in usercfg.txt. I undid that and made a xorg.conf in /etc/X11 with the following.

Section "Monitor"
    Identifier "LG24EN43"
    HorizSync 30-83
    VertRefresh 56-61
    Modeline "1920x1080R"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync

I then changed the display_rotate to 3 in usercfg.txt, rebooted, and voila it worked. No idea which part fixed it.

If anyone knows why it still can't detect the monitor, please let me know.

1 Like

Looks like my celebration was premature... I ran some updates, restarted, and now it's back to how it was. I'm completely out of ideas now besides reinstalling.