Disable lightdm on raspberry pi also disabled sound

I installed Ubuntu-Mate on a Raspberry Pi, since I am using it for robotic stuff and needed extra resources so I disabled lightdm (which improved performance a lot) with sudo systemctl disable lightdm. Since then I can't reproduce sounds with it (which I need). Not even aplay works.

If I start lightdm again, sound works again. However performance drops down.

I am almost sure ether lightdm or mate (which is started by lightdm) do something with ether alsa or pulseaudio, I just have no idea what.

Any idea?


the user is already on audio, pulse and pulse-access groups

Welcome to the Ubuntu MATE community, @fcolecumberri! I'm sure you'll get some ideas from others with more expertise in this area.

For ordinary Ubuntu I was needed to place my user into audio group.

Try the following command

sudo usermod -a -G audio $USER

and reboot.

The user is already on the audio group and still doesn't work. Also sudo aplay doesn't work aether, so I don't think it's a permissions issue.

Ok, I figured it out, when I disabled lightdm, I connected with ssh -Y <user>@<hostname>, the -Y forward the xservice. For some reason pulse uses the xservice so there were problems. I still don't understand why or how or if it is possible to forward the xservice without messing with the audio, but if I connect without the -Y flag, everything works fine.