Disabled on Upgrade


Any of you know happen to know of a post or site explaining clearly and for Newbies how to deal with all the "Disabled on Upgrade" that end up to be under the 'Other Software' of the 'Software and Updates' ??

Something like a simple not too techno guide saying How to replace PPA's for new versions, etc.

Just saying and saving lots of searches for those that just plain users.



Is this a test of some sort?

Control Center, Software Boutique

Test ? no
Using this, yes does upgrade installed packages.
But the 'Other Software' in the 'Software and Updates' still shows the "Disabled on Upgrade to.....".
So the newbie may be told to simply remove them.

If I remove only one of those disabled and close the 'Software and Updates', then it goes into a Cache Refresh and gets stuck there... no exit possible

I think I understand the question.

Select one and choose Edit. Change "disco" or whatever the old OS version was to "eoan" or whatever the new OS version is.

Oh, I see, my System > Administration > Software and Updates menu at 'Other' tab looks like that:
Winehq repo has been renamed and, probably, disabled during the last update. Since then it has been automagically enabled, though never has been renamed back.
In other words, it works despite the name, which can be edited back manually.

Understand. And what mdooley says surely does the job at updating/upgrading what need be.
But still, when going into System > Administration > Software and Updates menu at 'Other' and even when not changing anything it gets stalled (frozen) into Refreshing software cache, anyways when trying to close the window.


Have you tried logging out and back in since getting this (buggy) error? Or if not, rebooting?

Yes. Rebooting doesn't change anything.
The blue cursor moves a bit then get stuck.


Watford, you don't have anything pending in Software Boutique, do you? Nothing awaiting action in Bulk Queue? If not, have you tried Preferences, where you can, in the Advanced section, Manage Repositories?

Nothing pending in the boutique nor in Queue.
Advanced section > Manage Repositories leads me to Software and Updates anyways

And same happens


Please file a bug on this situation.