Disabling middle-click emulation - Mate 22.04 LTS


I have tried disabling three-finger click emulation in Mouse>Touchpad settings as well as enable middlemouse paste and emulate middle button through simultaneous left and right click in Mouse>Mouse but these are not working

Three finger tapping still closes a window on the taskbar - a major annoyance since there are so many spurious 3 finger taps on my laptop

Looking for a way to completely disable three finger tap and/or completely disable three finger tap closes windows on the taskbar

I have also tried gsettings set org.gnome.desktop.interface gtk-enable-primary-paste false to no avail

Disabling taps completely does works so I can only assume there is a bug with the mouse>touchpad settings