Disks | Read-only error after partitioning and crash after assigning name

I just formatted a USB drive with Disks and now get the following error message:

Only a few days ago I used this USB drive without any problems. Not sure what went wrong. It seems that Disks is always causing problems whenever I use it.

I’ve found Disks to format flash drives OK (like if they previously had an image written to them). Disks can throw timeout errors in the process sometimes and requires a second try.

Does the drive work again if you use GParted to create a new partition table and format a new partition? The other way is to try manually mount it, which could reveal if something is having trouble auto-mounting:

sudo mount /dev/sdaXY /mnt -o rw

(Changing /dev/sdXY to your drive, accessible in /mnt)

If the flash drive completely ends up read only, it’s likely to be a hardware problem – like corrupt or cheap/dodgy drives.

I just tried the same process with another USB and I get the same error message. I guess I must be doing something wrong on the way. Here's exactly what I did:

  1. Started Disks.
  2. Selected Format Disk > Overwrite existing data with zeroes (slow) + Compatible with all systems and devices (MBR/DOS) > Clicked _Format
  3. Clicked the green plus symbol to create partition in unallocated space
  4. Selected Erase: Quick and Type: FAT and gave it the name "Copy Shop"

It is mounting correctly as far as I know. The USB drive is correctly recognized in both Caja and Disks. I simply cannot copy any files onto it.

I am not sure if this problem is related to this error message:

Bug? :confused:

I just partitioned again but this time without assigning a name to the USB drive and it worked.
Each time I assign a particular name (in my case "Copy Shop") to a USB drive, Disks either crashes and I cannot partition at all or I end up having a partition with read-only (first error screenshot).

With GParted it works without any problems. The problem with Gparted is that it is not exactly beginner-friendly. Disks is too buggy and comes with a strange user interface. Are there any alternatives to these two?

Can you try copying the file via the terminal instead of Caja?
If that does work it could be related to https://github.com/mate-desktop/caja/issues/565 (which according to another thread here could also be a kernel issue, but either way, it seems like a common problem, also present in Nemo/Nautilus sometimes).

For some reason I cannot reproduce the first error message anymore. But I think it is covered by the issue you referred to. @maximuscore

The second error is probably a different one and seems to be triggered by assigning a name to a USB drive. With GParted I don’t have any of these problems.

Thank you both @lah7 and @maximuscore for your help. I don’t really have a solution but will most likely just use GParted for formatting and partitioning and hope for the Disks issues to be fixed in future releases.