Display Priority inconsistent

I seem to notice that when connecting an external Display to Ubuntu MATE, the priority set on which monitor is the primary monitor does not appear to be respected. It always seems dependent on location of the monitor on the Display settings area. Screenshot is attached.

I have a USB-C Thunderbolt capable Dock connected to a 25" Spectre Monitor with AMD Freesync ( Running at 1080p); My Laptop (ryzen 5 with built in Radeon Graphics) is using the Displayport over USB-C standard.

When I connect to the external display, all the program windows seem to go to the External display even though the Laptop Display is set as Primary. Also, the Welcome Screen always launches on the External Display no matter what display is set as primary.

DisplaySettings_2020-09-11 12-29-42

Hi :slight_smile:
As workaround you can use devilspie package.


I agree that it will not fix the main issue :slight_smile:

1 Like

I wish I had your issue. If I turn off my external monitor, everything moves to the laptop display even if I've turned it off in Display Settings. Worse when I turn it back on Same image in all monitors is checked.

Also I can't shutdown or reboot unless the laptop lid is open, otherwise I'm stuck in a logout-login in loop.

I usually use the system with the laptop closed and it slid under the 4K 45" LCD TV that I use as a monitor the 17" 1920x1080p laptop screen comes reasonably close to being 1/4 of the 3840x2160 UHD screen in physical size, but I don't have the desk space to keep them side-by-side.

This laptop (Asus fx705gm) has dual graphics chips NVidia 1060 and built in Intel HD.

I think the issue is coming from the dock. I have been looking for a lenovo dock for my USB-C capable computer running UM 18.04. For the moment i didn't bought it as I saw many compatibility issues with linux. What is the brand of your Dock ?
I saw that some USB 3.0 dock are more linux friendly than USB-C (If someone got experience with please share).

1 Like

Lenovo 40AS0090US

This is the specific model I have.

I think Gnome might have partially solved this issue in their latest version.