DNS problem inside virtualbox

I have a Windows program that will not run under Wine, PlayOnLinux or Crossover, so my only option seems to be to set up Windows XP in a virtualbox. The programs installs correctly, checks for updates, and updates itself correctly (so I do have Internet access).

When I go into the program, before it will download certain data files, I need to log into my Internet account for the program to check my registration information. The program now tells me that I have no Internet access. In fact, I cannot even access the program’s website using Internet Explorer from within virtualbox. I can access the website from Ubuntu Mate.

It would seem that the problem is either related to the DNS server within virtualbox, or the TCP/IP settings in network settings. I realize this may be outside the expertise of this forum, but I was hoping someone might have some suggestion if not a solution.



Hi @Jim007,

what is the name of the app you want to install?. :smiley:

I’m trying to install Wordsearch 10. I’ve checked the app database on winehq, but there’s no help on what’s needed to get it to work. PlayOnLinux doesn’t list it. I’ve tried installing using the “non-listed program” installer. It installs, but doesn’t update correctly and won’t install the data programs I have on disk. Crossover lists it and gives it 4 stars, but my results were no different from what I got with PlayOnLinux.

It seems that virtualbox is my only hope, but for some reason I can’t sign in to my account or access the website for the program from within virtualbox.


I do not know if this is any help, but thought I would throw it out there :slight_smile:

I think this is on the right track. It didn't solve my problem however. Still getting this error message.

Do you have any suggestions for firewall settings that might address this? I'm using GUFW with just the standard settings.


Hi Jim,

I cannot find anything relating to Wordsearch 10 but there are two different Bible apps in the Ubuntu repo’s which you can install directly and try them out!, open a terminal (Ctrl + Alt + t) and paste the following command which will install both apps for you:

sudo apt-get install bibletime xiphos

BibleTime is a free and easy to use bible study tool. It uses the Qt and SWORD software libraries. BibleTime provides easy handling of digitized texts (Bibles, commentaries and lexicons) and powerful features to work with these texts (search in texts, write own notes, save, print etc.) in the SWORD module format.

Xiphos is a Bible study program for the GNOME desktop environment, based on The SWORD Project by the CrossWire Bible Society, a framework for developing Bible study tools and of associated texts such as commentaries and dictionaries.

This package provides the main Xiphos program, a digital text reader with bookmarks and full-text search. It allows viewing multiple versions of the same text, for parallel reading of alternatives or translations. It also supports personal verse-specific notes and a rich-text study pad, both of which have spell checking and full-text search.

Thanks wolfman,

That solved that dilemma, but I now have another.

Is anyone besides me having trouble with the latest versions of virtualbox? Whenever I try to install windows in a new virtualbox my system is freezing/locking up forcing a hard reboot. After a couple of these I’m having to reinstall Mate. Right now I’m running in “recovery” mode because of all the crashes. Mate will not boot up in normal mode.

This is what I’m wanting to do with virtualbox: I have a gardening database program written for Windows 95/98. The name of the program is “The Gardener’s Notepad” and it was published by McCullum Software between 1997-99. It will load in Wine, PlayOnLinux, Crossover, and virtualbox running Windows XP. Under all of these, when I click on the “file” menu and select “create new database” the program crashes. It does the same thing in virtualbox when I try to run it in Windows 95 emulation mode.

It was a great program and there is nothing else that I can find on the market that does the same thing. I’ve thought about trying ReactOS in virtualbox, but before I do this I’m going to have to reinstall Mate and some older version of virtualbox that is more stable. Does anyone have any suggestions on a good stable version of virtualbox. Or is there another program that anyone is having luck with as a virtual machine?

I have been trying to debug the gardening program in wine. I noticed that PlayOnLinux is working on a Wiki that will eventually provide addin recommendations based on error messages from the debug program, but that isn’t complete yet. With the growing interest in gardening, I’ve thought about trying to design a database in libreoffice base, but it would certainly be helpful if I could get the program to open to see how all the tables are linked together.

Is there some place on the Internet that says, "if your game/program was designed to run under Windows ??, then the most common addins needed for wine to run your program are xxx, xxx and xx?



I haven’t used Virtualbox for a month or two now, but right before I last did I noticed a similar issue after Virtualbox updated. (I was using a Mac host to run Ubuntu.) I made it work at that time by uninstalling VB and reinstalling an older version from VB’s website.

Did you go back to version 3.xx or 4.xx?

I think it was an earlier 5.x.y release.

Have you tried downloading and installing the VirtualBox 5.1.12 Oracle VM VirtualBox Extension Pack?


HI @Jim007,

have you installed the package “winbind” (normally a good idea with Wine!)?, to do so via the terminal (Ctrl + Alt + t):

sudo apt-get install winbind

The restart your system!.

If you like reading ( a lot!):

See also: