Document Scanner

Running UMate 23.04.
Problem: all of a sudden, Document Scanner stopped working correctly.
Whenever I try to save a scanned document - on an Epson L3150 printer/scanner - I get the following error message:

Failed to save file

failed to execute child process"" (No such file or directory)

Individual pages will be saved, however, as "text-1", "text-2" etc but not the scanned document.
Help will be most appreciated, bearing in mind I am no techie...

first make sure your system is up to date and reboot, for me it gives that message, but then it does actually save it maybe try the xsane utility or maybe paperwork

1 Like

Question you have 23.04 and it actually worked correctly and stopped working as before?
Looked at driver page and seems it has epsonscan2 listed for scanner on your unit. Looked at install document but seemed to be in Japanese, but think it might also need sane. My scanner is older and had choice of the above driver and an older one. The new one did not work for me had to install the older version, but it doesn't show on your driver page.

Try in terminal

dpkg -l | grep sane

mine shows sane 1.0.14-16


dpkg -l | grep epson*

mine shows nothing as I don't have that driver epsonscan2
Just something you can try
Will say way better experience than earlier, had to add convoluted items to system to get scanner to work, works without them. :grinning:
looked more still could not find if sane is needed for epsonscan2

1 Like

I updated again the system and did one more reboot. Problem remained.
Then I installed xsane - and could not make it to scan multiple pages. Also tried paperwork buty, though I followed all procedures, failed to make my scanner recognized by it.

I also looked up in AskUbuntu. There are old posts about "Failed to save file // Failed to execute child process etc" but I could not find a satisfactory reply to these posts.

I enclose a screenshot of the error message I get when I try do save a scanned doc with more than one page into a file.

1 Like

Yes, Document Scanner used to work impeccably until a few days ago.
I reinstalled 'epsonscan2-non free plugin'. Situation did not change, problem persists.

Results from "

grep sane" and "grep epson*"


The good news is that EpsonScan2 is working. Correctly...

Fired up Document Scanner (AKA Simple Scan) and did not find option to save a .txt file. My only options are PDF, and 3 image files. Thus if I have 4 pages shown in scan screen and save as PDF end up with a single PDF file that has 4 pages in it as expected. Possibly a setting, here is sample.
Also did not check if your unit has feeder, could not totally check as mine doesn't. I do like it has a 4x6 preset for scanning photos.

1 Like

My Epson is a scanner/printer. It has no feeder.
Thanks for your tip, will try. But I am now very happy with Epson Scan2.

1 Like