Does Ubuntu MATE 20.04 support Driverless printing?

Having trouble with a USB-connected Brother HL L2321D laser printer (this is not a network printer... has neither LAN nor WiFi support) to my Ubuntu MATE 20.04 PC where by prints are erratically or partly successful. I can never print more than 1 or max 2 pages at a time. The manufacturer provided drivers are installed. The printer works flawlessly when connected to a Windows 10 PC.

Someone on another forum suggested trying Driverless printing, since Debian 10 added support for those. Brother website says that this printer model supports IPP protocol (though no claim of IPP-Everywhere that apprently includes IPP-over-USB support). If IPP-over-USB works, then hopefully the Driverless printing facility should work (assuming the issue to be an imperfect driver).

For the moment, I am struggling to troubleshoot because I'm not quiet sure how CUPS works ? The spool log shows all the c* and d* (control & data) files for all print jobs, each of them reporting "success", even if not a page of print came out. When such failed print jobs are fired, I see the printer "incoming command/data" LED (Ready LED) flash, but the drum/roller don't spin up, nor does a page come out. There is no jam, nothing.

I also have a Brother printer. Have you tried the support center?

Thanks for the reply. Yes, I have opened a ticket by mail, after providing all purchase information. Waiting to hear back.

I had similar problems, but not quite the same as you. I have a mfcj480 inkjet. Ubuntu 20.04 found it and it worked, but like you it would not print multiple pages until installed the printer, scanner and cups software. I think Brother has good Linux support, though not as good as HP, but I switched to Brother because I had nothing but trouble with HP hardware and ink cartridges.
Good luck, I hope you get it working quickly.