Doesn't wake up from sleep mode!

Hi to all the Community,

As the title mentions above, my computer never wakes up from sleep mode, I can keep moving the mouse or pressing the power button, nothing happens. I just have to press to reset power button to start it all again…
No problem though with the sleep mode in Windows 7 installed on my second hard drive !

In the meantime I find a solution, I have to keep my computer’s eyes wide open 24/7.
What can I do about it ?

You should try to find either a work-around or a solution by using Google. I’d search on phrases like “Ubuntu doesn’t wake up”, “Ubuntu 16.04 sleep mode not working”, phrases like that.

Askubuntu is a good site to look for answers for problems like this. Please report back on your efforts if you would. Good luck.

@Jonathan64 I have to use terminal commands on one of my machines because the off button doesn’t work for me, the machine reboots in 4 seconds. To put your computer to sleep, use

sudo pm-suspend

Perhaps pressing the spacebar several times will awaken the machine, or moving the mouse, or else try pressing the power button. This should bring the desktop right up and not cause a reboot.

Edit: This command depends on pm-utils but I think that this is included in a MATE install.

I too am experiencing this issue, but it’s intermittent, making it very difficult to figure out what’s causing the problem.

My first foray into the world of Linux on this machine (which I purchased specifically to install Linux) was with Mint. Mint had the same intermittent problem. I would put the machine to sleep (suspend) when the laptop was closed and occasionally it would not wake up. I would open the lid, I would see the screen do something (kind of a flicker) and hear either the fan or HD spin up, but then I would have only a black screen. I tried typing my password and hitting enter, but this did not work.
The only way to get the machine working was a hard reboot by holding down the power button.

Unable to find a solution to the problem, I decided to change distros. After some research, Ubuntu Mate looked like a great option (which it is!). However, it too seems to have the same issue. Again, it occurs when I put the machine to sleep and later attempt to wake it up. I open the lid and it brings up the login screen (so it’s getting farther than Mint seemed to) but the machine is frozen. No mouse movement and nothing happens when I attempt to enter my password (it’s not acknowledging that I’m typing anything). Only a hard reboot will get it going again.

The computer is a Dell Inspiron 15 (3558), which I selected because Dell actually sells Linux boxes and I figured their hardware would be happy with my ditching Windoze for Linux. But I’m wondering if there’s some hardware incompatibility I’m experiencing as I’ve now had this ‘wake up’ issue on 2 different distros.

If anybody has any suggestions for what I can check or change to try to stop this issue, I would greatly appreciate it. Unfortunately, because the issue is intermittent, I won’t know if something worked for several days (darn it).

Here’s some info about what I’m running, if it helps get the discussion rolling…
Release 16.04.2 LTS (Xenial Xerus) 64-bit
Kernel Linux 4.8.0-56-generic x86_64
MATE 1.12.1
Memory: 3.8 GiB
Processor: Intel® Core™ i3-5015U CPU @ 2.10GHz × 4
Available disk space: 672.8 GiB

I’ll admit I’m a novice with Linux, but folks here have been very good in offering direction so I’m feeling good about being able to try whatever is suggested.

Thank you in advance for any help!


I have ran into this problem also and boiled it down to my Graphics card
in one box I have a Radeon HD 6450 that would not (Sleep) it would get stuck in a weird loopy cycle trying to shut down but when it got to the point of powering off it would cycle back up, and would not stop until I pulled the power on it.

so I moved a Pentium Graphics card over (Not sure which one it is right off hand) to this box and it would have no issues going to sleep, waking or any of the above. I have since placed the old Radeon card back in.

To Me this situation sounds a lot like mine and I think your best bet is to look at your Video card.
Maybe there are some proprietary drivers you can try that will work…? Maybe try that older card you have sitting in your closet? or pillage your wife/whatever computer and play innocent when they can’t watch F is for Family on Netflix

Some people point the Video Card out, some others aim for the kernel version…
Some people managed to fix the problem with Additional Driver installation or with :
sudo apt-get install nvidia-current-updates
But it didn’t work for others…

In my case, I have a GTX 1070 so I should install NVIDIA drivers but as years go by I tend to be less confident of proprietary drivers for security reasons. (Hashtag Richard Stallman)

I really would like to find any other workaround, how come Nouveau as ‘drivers makers’ still haven’t fixed it while a lot of folks complain over that issue since older Ubuntu versions.

And I don’t find anything pertinent on Nouveau’s website…

Please try System, Lock Screen as a replacement for suspending your system. This work-around allows you to exit your existing session and sort of mimics a “wake up from sleep mode”. Please let us know if this work-around works or not. Thanks Jonathan.

Could you also let us know if the sudo pm-suspend works insofar as letting you wake up the suspended machine without a hard boot being required?

Hi all,
Nothing has worked for me
So I gave up and installed the proprietary drivers made by NVIDIA…
Now it all works smooth !

In my case, I feel condemned to install NVIDIA’s drivers with my GTX 1070.

The laptop I have isn’t fancy enough to have a separate graphics card. I’ve got the on-board intel graphics only on this Dell Inspiron. Is there some additional graphics driver I should be looking into?

One clue to know if the machine is going to be frozen when I wake it up is to see if the cursor is blinking when I wake it up and the login screen is presented. If it’s blinking, I’m good. If it’s not blinking, I know I’ll have to hold the 'ole power button down and do the hard reboot. I also noticed that pressing the caps lock key does not turn on the little associated light (not sure if that’s a useful clue, but thought I would toss it in there).

The issue is still totally intermittent, so any tests have to take place over a period of time (not sure if the issue being sporadic is a blessing or a curse).

I’ve not seen this issue on a couple of older laptops I’ve installed Linux on. Wondering if there’s some Dell specific hardware issue?

Thanks to everyone that’s thinking about this issue!


I tried this several times throughout the day and it worked just fine several times but did eventually re-create the "freeze-on-wake" issue. The one difference was putting the machine to sleep (suspend) using the "sudo pm-suspend" command did not bring up the login screen asking for my password when I woke it up, so it just eventually locked up on whatever screen I was on when I put it to sleep. Hard reboot was all I could do to get it working again.

I hope this offers a clue.


LOL! “You should try to use Google to find a work-around to solve this problem…”
And I came across this message!
Now using Ubuntu Mate 1710 which sleeps forever, or at least until I hold the power buttton for 7 seconds to shut the machine down!

No- it is not specific to Dell.
I now have it on my Acer Aspire-One which I just installed Ubuntu-Mate 1710 on.

Might still be hardware-specific.
I’m not experiencing this issue on an Intel N3150-based CLEVO laptop.

Hi all,

I know this discussion is old, but I thought I would post something that might offer some closure.

At some point, one of the regular system updates seems to have addressed this issue (because of how intermittent the issue was, I can’t say exactly which update did it). I have not seen this issue crop up in quite some time. I think somebody squashed this one.