Don't fallback to Raleigh theme when starting up / shutting down


I notice that when I still have running applications (particularly Steam) while shutting down the system, the desktop color scheme falls back to Raleigh, here's a screenshot:

I found out in /usr/share/themes/Raleigh/gtk-2.0/gtkrc it says:

# This theme is the default theme if no other theme is selected.

so I'm guessing it's intentional(?)

Now, as a workaround I replaced everything in Raleigh folder with AmbiantMATE, I also renamed some stuffs to "Raleigh" so it would work. It only works for the color scheme though, I still don't know how to fix those icons.

Lately I also notice it behaves the same when starting up the system (Raleigh theme loaded first, then my tweaked theme), it wasn't like that before, I don't know what causes it. Frankly it's quite annoying to see stuffs keep falling back to Windows95 vibe, no offense.

I think it would be nice if it falls back to my Ambiant by default, or even better, don't fallback at all.



I agree, first displaying one theme and then switching to another afterwards is kindof silly. I notice the same thing on my machines. If Ambiant MATE is the default, it should fall back to that if anything or just load the one theme you selected and only if that is broken/missing pick another.


I've noticed this too.
Usually occurs when power down hangs because of some running process.
It's also visible on startup especially on old systems running 5400rpm HDDs where I/O latency is high.


Note that with Gtk+ 3, Adwaita is not only the default, but it’s built-in to Gtk+ 3. Better to try to better fix the issue of switching to the default theme. I think it’s related to mate-settings-daemon not starting soon enough or quitting to soon.

1 Like

Speaking of gtk3, that problem seems to be gone in 16.10

1 Like