Don't work nvidia driver

Hi Serg,

I think the 364 package is for testing only?, you have the 361 package installed which is good!. :smiley:


Greetings to you too!. :smiley:

In the evening, I try to update the system, and again there was the same situation. Uninstall and reinstall the driver Nvidia 361.42, did not help. Again he fell back to a previous restore point. Driver Xorg not give that performance that Nvidia.

I have an Asus GTX 970 that was giving me the same problem after I upgraded from 15.10 to 16.04. When I dug in, I found that there was a problem with DKMS rebuilding the driver. I had some very disturbing pop-ups talking about my secure boot key not being valid. I found the option in my BIOS for secure boot, and switched it off (didn’t know I had it on, or that it had a password set). Now my monitor and the video modes are detected properly.

1 Like

Hi Serg,

how did you install?, disk or USB and did you follow this advice?:

I installed the beta version 2 flash disk. Then I do the update. Until yesterday, the update worked fine. BIOS worked uefi mode.
I have also realized that the problem with downloading uefi. I switch to compatible mode, but it did not work.
While I am working without the latest updates. I hope that this problem will be solved subsequent updates.

Have you done a complete system update?:

No. Thanks, will test.

1 Like

All happened through the “Welcome screen”. Thanks for the help.:smile::thumbsup:

Great to hear, please put a tick in best answer to mark it as solved so it helps others; thanks!. :smiley:

after update my problem again reappeared. As I understand it happens after a kernel upgrade from 18 to 21 version.

Open Welcome again and go to Software > Fixes > Resolve broken packages:

I did so, but did not help.


open a terminal (Ctrl + Alt + t) and paste the following command and restart if anything updates:

sudo apt-get update && sudo apt-get dist-upgrade -f

Do you have your software sources download location set to "Main server"?:

It happens all the same. It has something to do with the mode of operation uefi bios.

Can you switch from UEFI to legacy?. :smiley:

I do not think this is a good way to solve the problem. I now work in uefi mode. Maybe wait until this issue is resolved in updates. Probably not one I am suffering. While I will work without this update. I’ll try a different kernel.
I installed the update was a screen with the question “Disable uefi boot?”. Previously, such issues are not met.

And did you disable UEFI boot?. :smiley:

to any attempt to install another update BIOS tried to switch into compatibility mode, but the result was not.

After this update, an error occurs

Hi Serg,

did you run the updates shown in that window?.

Check the update guide again, boot into recovery mode and run dpkg (a network cable connection is required!):