DSC-HX60 SD card & camera on Ubuntu Mate

hi, i am in the transition process to Ubuntu Mate (after years of using Macs); so far everything is going well & i'm finding solutions to most of my problems, but there is one thing that i can't find any useful information for.

i have a sony cybershot DSC-HX60 camera and the SD card is specifically for this model. on both mac OS & windows it's possible to stick the SD card directly in, or connect the camera with the USB cable, & it just works. but not on my new Ubuntu Mate system.

i have looked for drivers and for other information about formatting the SD card, but i'm worried that if i format it for linux, then it's not going to work on other computers.

is it possible to format the SD card in a way that can be read by Linux, Mac & Windows?? & what do i need to do to be able to read the information on the camera via USB cable?


Hi and welcome
Can you please elaborate on what you mean by “it doesn’t work”?
Do you mean you can’t access your material on the SD card?
Do you see the card when you open the file browser?
Do you see the card when you open the Disk utility?

well this is interesting - as previously when i inserted the card i did not see anything at all, it didn't show up in the file browser. now, i inserted it again because i didn't know what you mean by the disk utility, so i wanted to look for it - & amazingly, the card is showing up in the file browser now!!

however, all the files are greyed out. i can navigate the directories on the SD card via the file browser, & see the lists of files, but i can't actually open or do anything with the files.

in Accessories i found something called Disks, is this the disk utility? the SD card shows up here, & it says it's OK.

and now i took the SD card out & put it back in again & i can access the files in the file browser!!!

sorry to have troubled you, i don't know what made it work but perhaps there is something a bit dodgy with the card ??

anyway thanks for the fast & helpful response :grinning:

i spoke a bit too soon - something is definitely not quite right. i ejected the SD card then put it back in, & now it doesn't show up again. i tried several times taking it in & out but nothing.

however i have tried again connected the camera with a USB cable, & it's working this way (although I couldn't get it to work this way earlier!).

i suppose it's more likely to be something wrong with the SD card than computer, if it sometimes works & sometimes not.

Yeah that’s weird.
Maybe the surface of the card is not very clean and contact doesn’t always happen when you plug it in?
Well at least apparently it’s not a problem caused by a required proprietary application so that’s good news.

i'll try cleaning it, & also i'll find another SD card & see if i have the same problems.
thanks very much for your help :slight_smile:

I’ve run into a similar problem with SD cards on Ubuntu. I would have to add ExFat and Fuse to get the card recognized with:
sudo apt-get install exfat-fuse exfat-utils
I’m not sure if Ubuntu Mate comes with these pre installed, but that may be the issue. I think Sony uses fat.

It does, at least for recent versions.
Both 16.04 and 17.04 ship with those packages.

i cleaned the SD card & tried it again today; it doesn't work in the SD card slot, but it does work when i plug the USB cable into the camera.
i'm on Ubuntu mate 16.04 & i do have exfat-fuse

the SD card did work, but only once, in the slot.

well it's strange - after using the cable to transfer my photos, i thought i'd try the SD card again ... & now it works!!! i don't understand, but at least it is sometimes working!

just to update on this issue: the SD card has not worked at all for about the last year. recently i upgraded Ubuntu & thought maybe after this it would work. but it still does not. basically i have given up even trying to use the SD slot, because it never works, & always have to carry a cable around with me.

This was very interesting reading. I have three mp3 players and made a similar experience. First, when I connected the first player via USB, and Caja didn’t show it, I thought my players are maybe Windows versions. On Mac, they don’t work at all, so Amazon reviews.
Recently, I installed UM 1804 on my second laptop and tried all 3 players and they were recognised. For some reason, the USB connections on my first laptop are not always working. I noticed that Caja gets confused when I disconnect player 1 and connect player 2. I have to restart the system, and then player 2 is recognised.
I have a Panasonic pocket camera and can only delete the images if I insert the SD card into the slot. I will try it over the weekend.

hi newhere, for me the usb cable connection always works. it's the SD card that only very occasionally has worked. i guess it must be something physical in either the card or the slot, since it did work a couple of times. i haven't yet got around to getting a second SD card to try.