Dudas de principiante

1.-¿que diferencias hay en los repositorios snap , flatpad y los propios de la distribución?, osea que cada dsitribucion tiene su repositorio o usa estos?
2-.¿por que hay programas que son para Gnu/Linux y no tiene la ultima versión estable?

Buenas Sadac,

  1. Si la distro está basada en ubuntu (Mate, Kubuntu, Xubuntu, Lubuntu...), usa el repo de Ubuntu. Ubuntu a su vez, toma de Debian, aunque en varias ocasiones precisa adaptar algunas librerias para que funcione. Snap no necesita de esas librerias compartidas, es decir, te instala todo lo necesario sin que tengas que actualizar dependencias. Tiene sus ventajas (no tienes que actualizar) e inconvenientes (pesa bastante más). En cuanto a flatpad, creo que se parece a snap, pero no te lo puedo asegurar.
    Los sabores de Ubuntu tienen a su vez algún tema o repositorio propio, licencias o adaptaciones (usan escritorios distintos, exploradores diferentes y programas más adaptados) que lo distinguen de los otros. Por ejemplo en Lubuntu, encuentras programas muy livianos, la precarga es más rápida y necesita menos RAM, pero queda limitado en cuanto a funcionalidad y estéticamente tiene bastantes restricciones (Mate is the best!).
    Te recomiendo que consultes el arbol de linux para saber de que fuente "bebe" cada distro o sabor. Esta image además muestra la linea de tiempo de desarrollo (muy interesante):
    https://external-preview.redd.it/_h7fSIEBHmsQGQX4Xg95bjJHYYK88YyWxAJmfSJtqaw.png?auto=webp&s=ba3038caf7708af7aa66ba82d00f578f4854a5ef

2.Porque han sido programados para una determinada versión de Kernel de linux, y no han sido todavía actualizados, o directamente no tienen mantenimiento, quedando desatendidos. No significa que no puedan "correr" en versiones más nuevas, pero no podrás actualizarlos y es muy probable que muchas de sus funciones no se ejecuten o te salgan directamente errores. Por ejemplo, durante un tiempo yo estuve usando una version de Adobe Reader para linux desatendida, y más o menos corría bién, pero el update y funciones algo avanzadas se colgaba. También es cierto que una versión desatendida tampoco corrige problemas de seguridad, lo cual siempre es un riesgo.

Saludotes.

1 Like

gracias, por tu tiempo