DVD and CD disks no longer recognized or mount after upgrade to 22.04

I just upgraded from 20.04 to 22.04 a couple of days ago and now my DVD drive is no longer recognizing any disks at all.... not store-bought movies, home-burned movies, or simple file backup DVDs!!! It was all working fine before the upgrade. All of my backup archives are on DVD disks, I need to get my (one and only) DVD drive working again ASAP!!!

So far I have tried:
sudo apt install libdvd-pkg (already latest version)
sudo dpkg-reconfigure libdvd-pkg (already latest version)
sudo apt install libdvdread8 (already latest version)

sudo lshw -C storage returns the following:

sudo lshw -C storage
description: SATA controller
product: ASM1062 Serial ATA Controller
vendor: ASMedia Technology Inc.
physical id: 0
bus info: pci@0000:06:00.0
logical name: scsi5
version: 02
width: 32 bits
clock: 33MHz
capabilities: sata msi pm pciexpress ahci_1.0 bus_master cap_list rom emulated
configuration: driver=ahci latency=0
resources: irq:27 ioport:4050(size=8) ioport:4040(size=4) ioport:4030(size=8) ioport:4020(size=4) ioport:4000(size=32) memory:d2b10000-d2b101ff memory:d2b00000-d2b0ffff
description: IDE interface
product: 6 Series/C200 Series Chipset Family Desktop SATA Controller (IDE mode, ports 0-3)
vendor: Intel Corporation
physical id: 1f.2
bus info: pci@0000:00:1f.2
logical name: scsi0
logical name: scsi1
version: 04
width: 32 bits
clock: 66MHz
capabilities: ide pm isa_compat_mode pci_native_mode bus_master cap_list emulated
configuration: driver=ata_piix latency=0
resources: irq:18 ioport:60d0(size=8) ioport:60c0(size=4) ioport:60b0(size=8) ioport:60a0(size=4) ioport:6090(size=16) ioport:6080(size=16)
description: IDE interface
product: 6 Series/C200 Series Chipset Family Desktop SATA Controller (IDE mode, ports 4-5)
vendor: Intel Corporation
physical id: 1f.5
bus info: pci@0000:00:1f.5
version: 04
width: 32 bits
clock: 66MHz
capabilities: ide pm pci_native_mode bus_master cap_list
configuration: driver=ata_piix latency=0
resources: irq:18 ioport:6070(size=8) ioport:6060(size=4) ioport:6050(size=8) ioport:6040(size=4) ioport:6030(size=16) ioport:6020(size=16)

I'm not sure why this is showing up as "ide" storage.
This is an old Dell Optiplex mini-format machine, but it is from 2012, so it is SATA, not ide.
I have 3 drives in this machine...
There are only 2 SATA ports available in total on the stock motherboard, so I had to add an internal SATA card for a second HDD.
The boot SSD is connected to the motherboard SATA port 0.
The DVD drive is connected to the motherboard SATA port 1.
A secondary storage HDD is connected to an internal PCIe card that is a combination SATA and USB2 "hub".

Both my hard drives are still working fine, but the DVD drive will no longer recognize or mount any media.
This is not the first time I have heard of this problem, but I still have not found any posts that offer a working solution.
Any help in getting this resolved asap would be appreciated.
Thank you.

Are you sure your drive still works?

I've had three DVDrw drives die the last six times I've used them; as they are just getting old & components fail. My failure-rate stats are terrible because I'm not replacing them with new drives/components; just grabbing a nearby drive from other old equipment that tests as fully operational prior to installation & my usage; but fails after installation (first usage lately).

Even good working components will fail with poor power; so check your PSU/power-supply. Spinning optical disks at speed needs a fair amount of power as motors are involved; it maybe your drive is no longer getting enough power to both spin the CD/DVD & then operate correctly.

Have you confirmed your hardware works?

I used CD/DVD media in QA, and noticed no differences in releases up to 22.10 (kinetic). Alas my (dell optiplex) primary PC's PSU finally gave out in that cycle; so my newer replacement box used in the 23.04 (lunar) cycle no longer has a DVD drive, and thus I stopped using optical media for any verification (without a need to test something specific), but I noted no difference up to 22.10 which includes where you're asking about.

I'm suggesting validate your hardware. I'd likely test it using live media; however if you have suspected PSU (power) issues that can influence the operation (ie. reading USB may use less power than a spinning-rust/HDD for example meaning more power is available to operate DVD drive).

The drive is fine, or it was before the upgrade. Everything still works with the drive, I can eject it via the GUI, so the system still sees the drive and can interact with it. When I place a disk in it it spins up and tries to read it, but then immediately spins down.

Unfortunately I don't have any live CDs to do boot test... like I said, the DVDs are my backup archives (music, photos, movies, etc)... I use USB sticks for live media installs or diagnostic booting. After I ran the upgrade to 22.04, there was an error about a broken package, that package was libdvd-pkg. I'm going to say with some confidence that this is an OS bug and not a hardware problem.

By booting live, I meant using USB-thumb-drive; which is why I stated

ie. the USB is where the live system is located and being run from; assuming its currently operating on HDD or SSD; thus its not a completely valid test (for issues with PSU if that's your problem).

A failed DVD drive can still work at ejecting, even spinning up, but can turn off as you describe due to component failure on the drive itself. Each of my failed drives did that too, but they refused to read/write media, and the easy fix for me was just to replace the drive with another.

If it's a software issue as you assert, booting & testing with live media should help prove that rather easily... alas it won't disprove hardware issues if it's PSU/power related (the newer release can cause a different drain on power due to different code; which can 'top' a just functional power supply into 'bad' for example; though this is a very 'edge' case; but will be confirmed in due course as power issues just get worse).

Another probably worthwhile test, is just to remove one (or two) of the drives on the machine & see if it operates then, as they won't be drawing power meaning more is available for the optical drive. If the DVD does operate correctly, you almost certainly (in my view) have power supply issues (your PSU can't provide sufficient power as it's now too old; total power capacity declines over time).

Others, may have different suggestions too. As I deal with old hardware a lot (and you mentioned a 2012 dell), my mind jumped to what I encounter numerous times per year...