Enable ssh on 64 bits raspberry pi 3 model b+ with ubuntu mate 18.04

I cannot enable ssh on raspberry pi 3 model b+ which is booted with ubuntu mate 18.04. I do not see ssh option in raspi-config interface tab.

The SSH server isn't preinstalled. You can install it for Ubuntu MATE using the Terminal:

sudo apt install openssh-server

:point_up: It can also be installed graphically under the Servers tab in Software Boutique.

If this is the latest version of UbM18.04, then I found the ssh server was installed, but no valid keys had been generated (see ssh service status forclue) - this wasn't the aarch64 version.

Though I've already installed ssh server on Rpi I still get the error message of connection closed by my pi ip address port 22

I have run into the issue with no ssh keys present. The following command should do the trick:

sudo dpkg-reconfigure openvn-server


Isn't it openssh one needs to reconfigure?

You are quite correct. My typo. dpkg-reconfigure is the magic command which it took me some time to find. Of course openssh-server is the application which needs fixing.



Same problem here:

I've installed Ubuntu MATE 18.04.2 (Bionic) on a Raspberry Pi 3B+. Then I wanted to enable ssh, but in raspi-config there is no entry for ssh even though openssh-server is installed.


The following magic command fixed the problem:
sudo dpkg-reconfigure openssh-server