Epson printer drivers no longer install

I have an Epson WF-3520 all-in-one printer. Have moving from Ubuntu Mate 14.04 LTS to Ubuntu Mate 16.04 I can no longer install the Epson printer drivers. A problem with a missing package lsb, which I read Debian no longer supports, an issue dating back to at least 2011 (see bug #bug 840998). I can’t see new users being able to find a fix for this, and personally I don’t want to have to hand craft the creation of symlinks. With issues like this no wonder GNU/Linux isn’t more widely used.

Hi @ayeUp ,

go here and search for the package by name, you can use Ubuntu 15.10 or lower as well I would say!:

5 posts were split to a new topic: Installing lsb packages in 16.04 for EPSON printer drivers

I had the exactly the same issue and found an external post - you don’t need to install dedicated Epson printer drivers in 16.04 - just use the following which worked perfectly for me:

sudo apt-get install printer-driver-escpr

After this I just went in to add the printer again which worked fine.


This is a great fix for me and my Epson WorkForce WF-3520 All-in-One printer (Simple-Scan & Xsane also work), many thanks.

1 Like

Thank you, jazi. Your solution worked like a charm with my Epson WF-2630. :joy:

1 Like

Worked well for an Epson XP-510, thank you :slight_smile:

This a great fix; worked perfect on Ubuntu 18.04.2 LTS and Epson WF-2750. Thank you so much.