Epson WF2750 Multifunction Printer scan issue

Hi all,

I just installed a Mate 19.10 (had Budgie 18.04 LTS before that) on my step mom's laptop.

Using the Epson printer files from the Epson driver page - one has to choose WF2670, which seems to include support for the 2570 - works nicely and seamlessly and prints the test page correctly.

Unfortunately the scanning option doens't work at all so far.

I downloaded the Epson Imagescan V3 printer drivers. Trying to install the .deb files in the core folder I had to download numerous libbost 1.65.1 .deb packages to get it to install.

I now hoave Imagescan working - but it's too complicated for my step mom to use.

Unfortunately Simple Scan and Skanlite both recognize the printer 'but when trying to scan both programs go into some kind of a lopp and need to be quit 'since they stay in that loop state.

Scanlite quits with the error message: operation cancelled and the output in the terminal is:
"1 instead of 0 arguments to message { DPI} supplied before conversion."
Trying to convert empty KLocalizedString to QString.

Simple scan has no terminal output and just quits after initially finding the scanner. When going for SCAN it starts the scan page and immediately quits.

Any suggestions on how I can have that fixed?

Hello monamtb

If you can not find an other solution, and you can spend a little money to solve the problem, you might find this information to be of use:

Good luck :slightly_smiling_face:

Hi Alpinejohn,

Thanks for the hint.
Unfortunately the device I have is a multi function printer so this won't work.

The funny thing was - it worked on Ubuntu Budgie 18.04 LTS - but my we couldn't deal with the small app icons in the desk bar.
Curious also though - Simple Scan worked with that flavor - yet Skanlite didn't.

I was hoping maybe this loop issue or the terminal output could be of help to fix the problem.

I also checked Vuescan's homepage - they seemingly have a driver for the Epson WF2750 - so in case no one has another option I guess that's my best bet ... but it's costly....

Hello monamtb

Yes, they do ask for money - but think about what you get if you buy the more expensive version (a) use on up to any 4 computers (running any OS or a mixture of OSs), (b) use on any scanners that you own, (c) updates for ever.
Look here (the link should point to their terms and conditions):

I've used Vuescan at work to keep a special legacy scanner working long after the manufacturer stopped providing a driver for newer win-doze systems.

I use HP printers and printer/scanners and have one or two old Cannon flatbed scanners still stored "just in case I ever need them again". If I had scanning problems I would try to keep my machines "going" with Vuescan.

By the way, have you tried installing "Xsane" and using it to reach your scanner? If that does not work for you my tipp remains Vuescan. Good luck. :slightly_smiling_face:

Hello monamtb

Question - are you connecting to the Epson via (a) a network cable, (b) a usb cable or (c) via wi-fi?

alpinejohn raises a good question. For what its worth, my canon is autodetected by
gscan2pdf but it is a very big download. But only works for USB lead not wireless etc

if interested it normally runs as GUI which should suit the oldie
sudo apt install gscan2pdf

then use menu to search for gscan2pdf and run it as a GUI


If not auto detected you can run it as a CLI and check your log.
gscan2pdf --log=scan.log
If a device needs to be specified (assuming it can be detected)
you could make a wrapper script for your step mom or better still modify the desktop file (found under /usr/share/applications/gscan2pdf.desktop)

my working CLI is not quite a match to lsusb but is
gscan2pdf --device='pixma:04A9180B_0581C8'

but I got that last bit from my log
lsub gives our first bit

dmesg | grep SerialNumber gives me the 0581C8

That is correct - I should have written that it is connected via USB cable

I tried GscanPDF - it recognizes the printer - just like all other programs - and then crashes for any unknown reason - so again - not usable at all.

And in terms of vuescan - it's actually cheaper to buy a new printer than to invest so much money into this kind of software. 15-20.- USD would be an amount to think about - but 50.- USD is way too much for this kind of software - Ubuntu would deserve that more than this kind of software.

I was simply hoping for a way to make simple-scan work like in Ubuntu Budgie 18.04 - where it did flawlessly - yet I have no insight into all the software that is needed or is different from the 19.04/19.10

Hello monamtb

OK, here is another idea to consider Skanlite (a KDE package:

I recommend you install it via "Synaptic" - if you do not know what Synaptic is don't worry - just reply saying you need help using Synaptic and I will reply.

I'm keeping my fingers crossed for you :slightly_smiling_face:

Hello monamtb

Lets look into the crashing...

I suggest you launch simplescan from a terminal and look at the terminal -output when it crashes.

To open a terminal: CTRL+Alt+T

At the terminal prompt (flashing cursor) type: simple-scan and then press "Enter".

If you are happy to share the output let us know what it says - this could help with the trouble shooting. :slightly_smiling_face:

To close the terminal: at the terminal prompt type:exit (or close the terminal window).

Hello AlpineJohn
I already did that in my first post.

And the problem exists with all other scan programs 'simple-scan, skanlite and x-sane.

The output in the terminal

Ooops - I forgot that... sorry.

Well, I am out of suggestions. :frowning_face:

how about posting the log then?
gscan2pdf --log=scan.txt

I changed log to a txt file that you can upload to dropbox so a link will clickable in my web browser or post it inside a code box if you have time.
scan.txt should be in your home dir

good luck

@monamtb - While I'd certainly encourage you to keep looking for a solution for as long as you have the patience to do so, since it worked on 18.04 I'd say your best option - if you can't find that solution - is to just go back to that.
I don't know what you mean by "small app icons in the desk bar", but that's probably fixable without too much trouble, whereas your mysterious loss of hardware support may not be. (It's very strange for a device to STOP working under Linux once the support first arrives, and my guess would be that the Beta is just broken right now and may end up working properly by the time it's released).

Since I am really new to this topic - do the scan programs provide their own drivers for the multi function printer devices or do I always need to install a device driver for the scanner provided by the manufacturer? Epson only offers the Imagescan driver/application as driver for the 2750/2650 WF range... at least that's what I found so far ....

I don't have dropbox or similar right now I could use - and the text file won't upload....

and I have no idea what a codebox is....

generally speaking we have front ends or GUI to backends.

generally speaking closed source packages tend to have their own driver set. I have had no need for any closed source Epson stuff but YMMV

Next when you reply you can see little icons and item 6 which has a </> can mean code box. Actually its not a real code box but a background highlight so when I write code above I use the Bold icon.

anyhow just post your log output. I just tested mine and its within the forum's word /character count


Although I invested more time than I wanted I found a solution that worked for me.

The Imagescan V3 driver seems to have caused all the hassle on the system.

  1. Researching I found that the Epson WF-2750 runs with the files of the Epson WF 2760.

Unfortunately, on the Epson driver website there is no driver entry for the WF2750 - one has to enter 2760 instead.

  1. I followed the protocol for the Epson Scanner setup from here:

I had to install the slxtproc file via synaptic first

I then downloaded the WF2760 driver here:

Make sure to get the : iscan-bundle-2.30.4.x64.deb package!!!!
The Epson website sometimes shows the imagescan-bundle-ubuntu-18.04-3.59.2.x64.deb package which caused all the trouble and wasn't working for me.
It seems to offer it differently. When I tried to look for the deb package from Epson now - it would only show the (for me) non-working Imagescan3 bundle.

The only link I could find now was this:

But then one would have to know how to create a package which I don't.

Maybe someone can add this to this discussion.

  1. I used the > sudo sane-find-scanner< command to get my scanner data

  2. According to the article I checked the iscan file in the appropriate folder as root . and >epkowa< was already an entry.
    Since >epkowa< was entered I checked the epkowa.conf file - entered the appropriate data that I got from the >sudo sane-find-scanner< command.

Then I ran simple scan and now all scan programs work the way they should.

Whatever is wrong with this Epson Imagescan V3 driver I don't know - but it cost me huge amount of time and wasn't working properly at all - for whatever reason.

Now my step-mom is happy again since she can use the program she is used to :slight_smile:
I'll leave this discussion open until someone can maybe create the deb file from this source file package.

Thanks for the help, time and ideas of all involved.