Error following todays software update

Uploading...

Tried running the application again and this doesn't work :frowning:

Hi @stoswald,

you would be better of using Synaptic package manager to install the package, to install Synaptic use the following terminal command (Ctrl + Alt +t) then search for the package.

sudo apt-get install synaptic

If you want to try installing both Synaptic and the fonts installer, use the following:

sudo apt-get install synaptic ttf-mscorefonts-installer

This seems to a problem across the board no matter how you try and install it from the repos (terminal or synaptic). I installed Wine recently and had a right job getting this fixed. I finally fixed it by doing this:

  1. open a terminal and type:

sudo apt-get remove ttf-mscorefonts-installer
sudo apt-get purge ttf-mscorefonts-installer
sudo apt-get autoremove
sudo apt-get update

  1. download the following file and install/reinstall via gdebi

http://launchpadlibrarian.net/184515877/ttf-mscorefonts-installer_3.4+nmu1ubuntu2_all.deb

Run software updates again either by GUI or in a terminal with sudo apt-get update and sudo apt-get upgrade, in that order, and you should find your problem has gone.

1 Like

You can try

sudo apt install -f

As the package name implies, this package doesn’t include the fonts themselves, just an installer for the fonts. This is because Microsoft released their “core fonts for the web” as freeware but with restrictions on distribution, so Debian and Ubuntu don’t host the fonts themselves. After the package installs, it downloads fonts files from Sourceforge, which mean that even if the package installs ok, and even if the Ubuntu repos are working fine, it will fail to install the fonts and show that message if the installer can’t reach the downloads on Sourceforge. When this has happened to me, sometimes it will work if I try again right away by removing and reinstalling the package, but sometimes I’ve had to wait for a day a so before it’s worked again.

Hello. This is a confirmed bug in Xenial Xerus (16.04) . As a workaround, you must uninstall this package sudo apt-get remove ttf-mscorefonts-installer
sudo apt-get purge ttf-mscorefonts-installer
sudo apt-get autoremove
sudo apt-get update
then download the 3.6 version of ttf-mscorefonts-installer with command wget http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb -P ~/Downloads from Debian. This will download the package to your Downloads folder, and sudo apt install ~/Downloads/ttf-mscorefonts-installer_3.6_all.deb. Good luck.

3 Likes

I’m sure I’ve seen that error, or something similar (… Can’t drop privileges for downloading as file …) in the terminal when installing the package, but the fonts definitely get installed for me. (I gotta have Georgia!)

Edit: Just to be clear, I’m not saying that bug’s not real for you or other users. It’s just an observation because I was concerned about the error message when I saw it, but the fonts installed OK for me.

Hello again :slight_smile: No, fonts is not installed :frowning: andale32.exe is not installed. Looks like the package itself (ttf-mscorefonts-installer) installed ok and then failed when downloading the actual fonts from sourceforge.
It is right to be concerned that the font files could be corrupted, because they are hosted on SourceForge, which recently decided to wrap sleazeware around others’ software (even though this is specifically prohibited in the fonts’ EULA). t might be best for someone else (GitHub? Ubuntu?) to host these files to make sure SourceForge doesn’t corrupt them. It is possible that this (or the SourceForge “cookies” popup) is the root cause of this problem, though I have not pursued that.

I was worried about Sourceforge, too, but it was purchased (along with Slashdot) earlier this year, and the new owners say they will change the bad behavior.

The work around worked thank you Ogis1975

See here https://ubuntuforums.org/showthread.php?t=2344990

2 Likes