Etc/init or etc/init.d to boot into text only mode

New to linux & Pi

have installed openSSH and got it to start from boot & it works from a remote system.

How to I configure the start up process (Upstart or init) so that the GUI is not started and boot goes straight into text mode/terminal?

Is there any official documentation?

Hi venerley, welcome to the forums :slight_smile:

We have a raspberry section and I moved you there. I don’t own one, so have to wait for someone else to come along. There’s docs on upstart, is that what pi uses? The regular desktop install uses systemd.

Thanks for the guidance. Being new to Linux I am even newer to the start up process and the Ubuntu deviation from the norm. This is the first time I have heard of systemd ! so thanks for making me aware of it.

V.

1 Like

Here’s a handy search tool.

http://www.googlubuntu.com/results/?cx=006238239194895611142%3Au-ocqbntw_o&cof=FORID%3A9&ie=UTF-8&q=boot+to+text+mode&as_qdr=all&sa=Google+Search&lang=en

Just editing the grub file works nice for me, but again , not sure if this applies to Pi.

Good luck :slight_smile:

Hi @venerley,

does this help?:

Wolfman thanks for the post.

Should this work for UbuntuMATE? which I am running.
I just tried “sudo raps-config” and got the response “raspi-config: command not found”. I was under the impression that the “raspi-config” was for ‘raspian’ users?

I have found UbuntuMATE “Boot-Up Manager”, however I would prefer to learn and understand how to perform this setup from the command lined which will force an understanding of the boot & startup process and architecture.

I might disable “lightdm” in “Boot-Up Manager” and try and determine how it effects the various scripts that control boot up. Any wisdom gratefully accepted.

Sorry but I don't have one (RaspberryPi) so I cannot really be of any further help to you!. :frowning:

Should be independent of h/ware in the case of UbuntuMATE as it is a desktop build I think. Anyway thanks for the input.

1 Like

Hi, could you try this :
systemctl set-default multi-user.target --force
systemctl disable lightdm.service --force
systemctl disable graphical.target --force
systemctl disable plymouth.service --force
Then reboot.
Replace disable with enable if you wish to boot to desktop again.