Ethernet not working with 16.04

Hello there,
after fresh install of UM 16.04.1 on a PowerBook G4, ethernet connection is not working (Desktop notification showing Disconnected, while connected).
Wifi connection work after b43legacy driver install, so system is up to date.
I tried to change cable and port on my box, reboot the box, but it don’t work.
Thanks for any help.

Please provide the output of the command:

lshw -C net


thanks for your help.
Output :

description: Network controller
produit: BCM4306 802.11b/g Wireless LAN Controller
fabriquant: Broadcom Corporation
identifiant matériel: 12
information bus: pci@0000:10:12.0
version: 02
bits: 32 bits
horloge: 33MHz
fonctionnalités: pm bus_master cap_list
configuration: driver=b43-pci-bridge latency=16
ressources: irq:52 mémoire:a0004000-a0005fff
description: Ethernet interface
produit: UniNorth 2 GMAC (Sun GEM)
fabriquant: Apple Inc.
identifiant matériel: f
information bus: pci@0001:24:0f.0
nom logique: enP1p36s15f0
version: 80
numéro de série: 00:0a:95:a0:b6:b0
taille: 10Mbit/s
capacité: 1Gbit/s
bits: 32 bits
horloge: 66MHz
fonctionnalités: bus_master rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=sungem driverversion=1.0 duplex=half latency=16 link=no maxlatency=64 mingnt=64 multicast=yes port=MII speed=10Mbit/s
ressources: irq:41 mémoire:f5200000-f53fffff mémoire:f5100000-f51fffff
description: Interface réseau sans fil
identifiant matériel: 1
nom logique: wlan0
numéro de série: 00:03:93:eb:fe:89
fonctionnalités: ethernet physical wireless
configuration: broadcast=yes driver=b43legacy driverversion=4.4.0-45-powerpc-smp firmware=295.14 ip= link=yes multicast=yes wireless=IEEE 802.11bg

Please shut off your wifi, plug in the ethernet cable, then run the command:

ping -c10

And provide the output.

If you get PING replies it means the applet doesn't show connected, but you are indeed connected.
If you don't get PING replies it means there's a driver problem.

ping output with wifi off and ethernet plugged:

connect: Network is unreachable

Salut @solarbop

Hopefully this was already considered from your end but can you confirm that there 2 LEDs that are ON when your RJ45 cable is plugged into your machine?

If not, then your cable’s to blame.

LEDs are effectively OFF on the box, even when i plug another cable who works on another machine

Sticking to my own personal experience, it’s possible that the head of the cable is loose and, yes, sometimes I have seen a RJ45 cable that worked and then stopped working at the next reboot (I actually have this problem on my HP laptop running MATE 16.10 and I’ve been too lazy to redo the cable head as it’s mostly been running fine after having re-reseated the cable back in the jack).

I have also seen the case in which a RJ45 working fine on one machine started giving problems when being plugged into another totally different machine.

I guess my real point here is according to your output, your NIC’s driver seem fine and the problem is elsewhere.

Another thing you could try is boot using any other LIVE DVD with the cable that you know works.

What’s the result of that?

Hope this helps,

This is a hardware issue. Your cable is defective or your router needs it to be crossover or the ethernet port of your router or your machine is broken. Trying with a cable that you know works and a computer that works to play with your router will tell you if the problem is the router or your machine.
Tip: the router has 3 or 4 ethernet (rj45) slots to try on.

I tried with 4 cables who works : same problem
I tried different slots on my router : same problem
I tried with other live CD (Lubuntu 16.04 powerpc, Ubuntu 12.04 powerpc) : same problem
Mayby ethernet port of my machine is broken… but how do Icheck it ?

Any other idea ?

The probable problem is that someone tried to plug in a RJ11 plug into the ethernet jack bending or breaking a couple of the connections in the jack. Usually the outer two wires are bent or broken.

The way to check it I would say it's done. Now the way to replaced it without a technician is with and USB-Ethernet adapter:

1 Like

I have had lan/wlan/internet problems with various computers at various sites. The last problem was connecting to a raspberry pi with a network cable. It may be related. Here is what (appears to have) fixed it. Yours will vary because yours is wifi.
Click on [System tab] >[Control Center] > [Network Connections] > Select [Eternet connection 1] >[Edit] > select [IPv 4 Settings] {Method: dropdown arrow} > Seletct [Shared to other computers]> [Save]
I also have [Require IPv4 …] checked.
I don’t know why this worked or for how long. It may be a security risk on wifi. I just don’t know. Most of my wifi were set to [Auto …(DHCP)] but one had the Shared selected.
I hope it helps someone.

Thanks to all, it seems to be a hardware issue.
It works perfectly with an USB-Ethernet adapter.
I’ll let you now if something changes.