External Camera suddenly does not work

Hello, up till some days external camera worked fine, suddenly - after an update - not, tested camera on a laptop where it works, tested camera on my other desktop (which I do not use regularly) it worked, too - until I updated.
Got already some great help on other fora - up to now unfortunately nothing helped....
Kernel on desktop(s) is: Kernel 5.4.0-96-generic
on laptop: Kernel 5.13.0-27-generic
ls -l /dev/video0 on desktop says:
ls: Zugriff auf '/dev/video0' nicht möglich: Datei oder Verzeichnis nicht gefunden
on laptop same command
crw-rw----+ 1 root video 8, 0 Jän 31 23:58 /dev/video0


Hello BuelentR

You could try installing the package "guvcview" via the Synaptic package manager. Then launch guvcview and see if it can work with your webcam. Good luck. :slightly_smiling_face:

I had the same problem on my laptop. I tried "guvcview" and "webcamoid". Both worked when "cheese" would not. Personally I stuck with "webcamoid".

Thanks, but I have guvcview installed already. Camera does not work with any of them: Cheese, Webcamoid, Zoom, Skype....
Thanks anyway, aboslutely no idea. When starting MATE from stick or Linux Mint, camera works...

Does the stick have a different kernel than the laptop? I have had that happen with my Broadcom WIFI, twice kernel updates failed to support it. Can you boot into your old kernel and see if the camera works under the old kernel?

Go same/similar advice in another forum (ubuntuusers.de). Did everything, updated to a Kernel (5.13.0-28-generic) with which laptop works and where external camera works by the help of a forum member (for me this is somewhat scary) - but it did not work out either.

I was talking about booting to safe mode and going back to an old kernel that worked, not updating to a new kernel. Going back to an older kernel may no longer be a option if you ran autoremove, ubuntu cleaner or bleachbit as root after you updated to the newer kernel.

Thank you, unfortunately that is what I did: Ubuntu Cleaner...