External drive (WD Elements) problem

Ubuntu Mate 16.04

I was playing a movie located on the external (WD Elements), and suddenly VLC gave me input/output error.

Went to Disks, stopped the partition ,only to find that indeed i don’t have an option to checkdisk

then installed gparted , which was loading endlessly looking for /dev/sdb

looked up on internet , tried many suggested commands, most of which showed no sign of /dev/sdb except for the 2 following commands

i suspect a physical damage since the external makes a “tsk… tsk” sound as the disks spin. at some point they stop spinning , i suppose at 180 seconds as described in the output

dmesg | tail -n 20

[ 1402.276632] sd 8:0:0:0: [sdb] Read Capacity(10) failed: Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[ 1402.276647] sd 8:0:0:0: [sdb] Sense not available.
[ 1402.276771] sd 8:0:0:0: [sdb] Write Protect is on
[ 1402.276779] sd 8:0:0:0: [sdb] Mode Sense: ee ee ee 00
[ 1402.276850] sd 8:0:0:0: [sdb] Attached SCSI disk
[ 1404.124106] usb 1-2: new high-speed USB device number 4 using ehci-pci
[ 1404.257240] usb 1-2: New USB device found, idVendor=1058, idProduct=1048
[ 1404.257261] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[ 1404.257273] usb 1-2: Product: Elements 1048
[ 1404.257283] usb 1-2: Manufacturer: Western Digital
[ 1404.257294] usb 1-2: SerialNumber: 575832314138333236393231
[ 1404.258987] usb-storage 1-2:1.0: USB Mass Storage device detected
[ 1404.266771] scsi host9: usb-storage 1-2:1.0
[ 1405.265883] scsi 9:0:0:0: Direct-Access     WD       Elements 1048    1022 PQ: 0 ANSI: 6
[ 1405.272491] sd 9:0:0:0: Attached scsi generic sg2 type 0
[ 1405.275315] sd 9:0:0:0: [sdb] Spinning up disk...
[ 1406.280083] .....................
[ 1427.395424] nf_conntrack: automatic helper assignment is deprecated and it will be removed soon. Use the iptables CT target to attach helpers instead.
[ 1427.428087] ......................not responding...
[ 1628.578324] sd 9:0:0:0: timing out command, waited 180s

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 046d:09b8 Logitech, Inc. 
Bus 001 Device 004: ID 1058:1048 Western Digital Technologies, Inc. Elements Portable (WDBU6Y)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

So, can we bring some life back to the external? Thanks in advance

There are many WD Elements drives, so I apologize if this advice is off target for yours. With the symptoms described [sound tsk … tsk] I suggest trying these steps insure the hd is receiving sufficient power:

  1. Make certain your pc is plugged into AC and try again
  2. Attach to a different pc or different USB port
  3. Attach a power supply to the WD Elements HD

There’s no magic in the order; any change in symptoms post back with results.

Thank you for your reply,

  • I have tried it on our 2 laptops and pc, same clicking sound everywhere. in fact my pc (Mint) would not completely power off until i unplugged the external from it.

  • i tried almost all usb ports available

  • this laptop has a dead battery so it’s always connected to electricity via a UPS, so as the pc. but my other laptop is directly connected to electricity

  • there is no power supply for this model. i wonder if there’s a special cable one should use?

Thank you again for replying :slight_smile:

Maybe try another USB cable???
please respond with the model # on the case…searching for idProduct=1048 in your original post didn’t help me

Gut feeling here - the hd is on it’s last leg :cry:

Thank you again for replying,

P/N: WDBUZG0010BBK-001
so this is the one: http://www.amazon.com/Elements-Portable-Drive-Storage-WDBUZG0010BBK-EESN/dp/B00CI3BLPA

I don’t suppose i have another cable of the kind. but i will check again. it looks like the one on this page: http://www.wdc.com/en/products/products.aspx?id=470#Tab2

we are both sharing the same gut feeling, but one can only persevere! :persevere:

Searching for your symptoms and exact hard drive returned a number of possibilities - WD site

Two YouTube videos that involved a procedure not recommended - taking apart the drive itself. The cause of the tsk tsk sound is probably the disk heads being stuck to the recording surface. Modern hard drive heads actually “fly” over the recording surface in the nanometer range. Think flying a 747 6" above the ground.