External Seagate HDD

Hello all
I can't seem to delete, rename, move etc files frome my external Seagate 1TB USB drive getting an input/output error. If I go into a sub folder on the external drive I can do all these things (delete, move rename ETC) from there. The external USB drive is formatted as NTFS. Does any one have any idea where I can start to troubleshoot this? I don't think permissions are a concern in a NTFS drive, right? I am running Linux Mint 19.3 on a Lenovo T430 laptop. I haven't had this problem until recently, like a couple of days.
Thanks:
Rich

with the drive plugged in, what the output of sudo mount | grep media

Here you go :
/dev/sdb3 on /media/richhelen/Lenovo Timeshift type ext4 (rw,nosuid,nodev,relatime,stripe=8191,data=ordered,uhelper=udisks2)
/dev/sdb2 on /media/richhelen/Spare_backups type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/sdb1 on /media/richhelen/Seagate Expansion Drive type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
[email protected]:~$

Here is blkid from terminal

/dev/sda1: UUID="a693fde7-85d5-4704-8897-d24e6d447abb" TYPE="ext4" PARTUUID="e875f687-01"
/dev/sdb1: LABEL="Seagate Expansion Drive" UUID="86EA6612EA65FEB5" TYPE="ntfs" PARTUUID="5fd3a9c8-01"
/dev/sdb2: LABEL="Spare_backups" UUID="111937940217668D" TYPE="ntfs" PTTYPE="dos" PARTUUID="5fd3a9c8-02"
/dev/sdb3: LABEL="Lenovo Timeshift" UUID="0174aab8-33da-49c8-93f5-fe9756b51c83" TYPE="ext4" PARTUUID="5fd3a9c8-03"

do you have an entry for that partition (/dev/sdb1) in your /etc/fstab?

also, ls -l /media/richhelen/
(the mount point is 'Seagate Expansion Drive' and owner/group should be richhelen as 755)
Not sure if the spaces in the mount point cause an issue.

Here is (ls -l /media/richhelen) from terminal

total 48
drwxr-xr-x 4 root root 4096 Jul 29 09:42 'Lenovo Timeshift'
drwxrwxrwx 1 richhelen richhelen 12288 Jul 29 18:14 'Seagate Expansion Drive'
drwxrwxrwx 1 richhelen richhelen 32768 Jul 29 11:33 Spare_backups
[email protected]:~$

AFAIK there is a whole lot of possible reasons for NTFS drive erratic problems. Many of them have the following common root cause: NTFS artefacts persist when HDD is disconnected while Windows is not shutdown.
Hopefully you might find these links useful:


Windows is not being used here at all, only Linux Mint 19.3 . This external HDD has never been used or connected to a windows machine. The drive came out of the box formatted as NTFS. I did partition extra smaller parts, one as NTFS the other as Ext4.
Thanks for the reply's

There is no listing in fstab for this drive or any of its partitions. Mount point js /Media/user name/Drive name.

Are you able to write into that drive

touch /media/richhelen/'Seagate Exapansion Drive'/testfile

and delete that file afterwards?

[Solved] Well, I Used a relatives windows 10 machine and ran in the cmd "chkdsk /f /r /x" and everything on my Seagate Expansion drive was fixed. I can use it fully now. So easy. Took about 4 hrs to complete on a 1TB external USB HDD. Tried all sort of things in Mint 19.3 but nothing worked. I guess only Windows can fix NTFS corrupted drives.
Thanks to all.